Debian-Sicherheitsankündigung

DSA-1098-1 horde3 -- Fehlende Entschärfung der Eingabe

Datum des Berichts:
14. Jun 2006
Betroffene Pakete:
horde3
Verwundbar:
Ja
Sicherheitsdatenbanken-Referenzen:
In Mitres CVE-Verzeichnis: CVE-2006-2195.
Weitere Informationen:

Michael Marek entdeckte, dass das Horde-Rahmenwerk für Webapplikationen nur eine unzureichende Entschärfung der Eingabe durchführt. Dies kann zur Einschleusung von Webskriptcode mittels Site-übergreifendem Skripting führen.

Die alte Stable-Distribution (Woody) enthält das horde3-Paket nicht.

Für die Stable-Distribution (Sarge) wurde dieses Problem in Version 3.0.4-4sarge4 behoben.

Für die Unstable-Distribution (Sid) wurde dieses Problem in Version 3.1.1-3 behoben.

Wir empfehlen Ihnen, Ihr horde3-Paket zu aktualisieren.

Behoben in:

Debian GNU/Linux 3.1 (sarge)

Quellcode:
http://security.debian.org/pool/updates/main/h/horde3/horde3_3.0.4-4sarge4.dsc
http://security.debian.org/pool/updates/main/h/horde3/horde3_3.0.4-4sarge4.diff.gz
http://security.debian.org/pool/updates/main/h/horde3/horde3_3.0.4.orig.tar.gz
Architektur-unabhängige Dateien:
http://security.debian.org/pool/updates/main/h/horde3/horde3_3.0.4-4sarge4_all.deb

MD5-Prüfsummen der aufgeführten Dateien stehen in der ursprünglichen Sicherheitsankündigung zur Verfügung.