Debian-Sicherheitsankündigung

DSA-1099-1 horde2 -- Fehlende Entschärfung der Eingabe

Datum des Berichts:
14. Jun 2006
Betroffene Pakete:
horde2
Verwundbar:
Ja
Sicherheitsdatenbanken-Referenzen:
In Mitres CVE-Verzeichnis: CVE-2006-2195.
Weitere Informationen:

Michael Marek entdeckte, dass das Horde-Rahmenwerk für Webapplikationen nur eine unzureichende Entschärfung der Eingabe durchführt. Dies kann zur Einschleusung von Webskriptcode mittels Site-übergreifendem Skripting führen.

Die alte Stable-Distribution (Woody) enthält das horde2-Paket nicht.

Für die Stable-Distribution (Sarge) wurde dieses Problem in Version 2.2.8-1sarge3 behoben.

Die Unstable-Distribution (Sid) enthält kein horde2-Paket mehr.

Wir empfehlen Ihnen, Ihr horde2-Paket zu aktualisieren.

Behoben in:

Debian GNU/Linux 3.1 (sarge)

Quellcode:
http://security.debian.org/pool/updates/main/h/horde2/horde2_2.2.8-1sarge3.dsc
http://security.debian.org/pool/updates/main/h/horde2/horde2_2.2.8-1sarge3.diff.gz
http://security.debian.org/pool/updates/main/h/horde2/horde2_2.2.8.orig.tar.gz
Architektur-unabhängige Dateien:
http://security.debian.org/pool/updates/main/h/horde2/horde2_2.2.8-1sarge3_all.deb

MD5-Prüfsummen der aufgeführten Dateien stehen in der ursprünglichen Sicherheitsankündigung zur Verfügung.