Bulletin d'alerte Debian

DSA-1100-1 wv2 -- Dépassement d'entier

Date du rapport :
15 juin 2006
Paquets concernés :
wv2
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2006-2197.
Plus de précisions :

Une erreur de vérification de limite a été découverte dans wv2, une bibliothèque de lecture de documents Microsoft Word, qui pouvait mener à un dépassement d'entier lors du traitement de fichiers Microsoft Word.

L'ancienne distribution stable (Woody) ne contient pas wv2.

Pour l'actuelle distribution stable (Sarge), ce problème a été corrigé dans la version 0.2.2-1sarge1

Pour la distribution instable (Sid), ce problème sera bientôt corrigé.

Nous vous recommandons de mettre à jour vos paquets libwv.

Corrigé dans :

Debian GNU/Linux 3.1 (sarge)

Source :
http://security.debian.org/pool/updates/main/w/wv2/wv2_0.2.2-1sarge1.dsc
http://security.debian.org/pool/updates/main/w/wv2/wv2_0.2.2-1sarge1.diff.gz
http://security.debian.org/pool/updates/main/w/wv2/wv2_0.2.2.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/w/wv2/libwv2-1_0.2.2-1sarge1_alpha.deb
http://security.debian.org/pool/updates/main/w/wv2/libwv2-dev_0.2.2-1sarge1_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/w/wv2/libwv2-1_0.2.2-1sarge1_amd64.deb
http://security.debian.org/pool/updates/main/w/wv2/libwv2-dev_0.2.2-1sarge1_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/w/wv2/libwv2-1_0.2.2-1sarge1_arm.deb
http://security.debian.org/pool/updates/main/w/wv2/libwv2-dev_0.2.2-1sarge1_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/w/wv2/libwv2-1_0.2.2-1sarge1_i386.deb
http://security.debian.org/pool/updates/main/w/wv2/libwv2-dev_0.2.2-1sarge1_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/w/wv2/libwv2-1_0.2.2-1sarge1_ia64.deb
http://security.debian.org/pool/updates/main/w/wv2/libwv2-dev_0.2.2-1sarge1_ia64.deb
HPPA:
http://security.debian.org/pool/updates/main/w/wv2/libwv2-1_0.2.2-1sarge1_hppa.deb
http://security.debian.org/pool/updates/main/w/wv2/libwv2-dev_0.2.2-1sarge1_hppa.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/w/wv2/libwv2-1_0.2.2-1sarge1_m68k.deb
http://security.debian.org/pool/updates/main/w/wv2/libwv2-dev_0.2.2-1sarge1_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/w/wv2/libwv2-1_0.2.2-1sarge1_mips.deb
http://security.debian.org/pool/updates/main/w/wv2/libwv2-dev_0.2.2-1sarge1_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/w/wv2/libwv2-1_0.2.2-1sarge1_mipsel.deb
http://security.debian.org/pool/updates/main/w/wv2/libwv2-dev_0.2.2-1sarge1_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/w/wv2/libwv2-1_0.2.2-1sarge1_powerpc.deb
http://security.debian.org/pool/updates/main/w/wv2/libwv2-dev_0.2.2-1sarge1_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/w/wv2/libwv2-1_0.2.2-1sarge1_s390.deb
http://security.debian.org/pool/updates/main/w/wv2/libwv2-dev_0.2.2-1sarge1_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/w/wv2/libwv2-1_0.2.2-1sarge1_sparc.deb
http://security.debian.org/pool/updates/main/w/wv2/libwv2-dev_0.2.2-1sarge1_sparc.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.