Bulletin d'alerte Debian

DSA-1106-1 ppp -- Erreur de programmation

Date du rapport :
10 juillet 2006
Paquets concernés :
ppp
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2006-2194.
Plus de précisions :

Marcus Meissner a découvert que le module additionnel winbind pour pppd ne vérifiait pas si l'appel à setuid() était réussi lors d'une diminution des droits, qui pouvait ainsi échouer dans le cas de certaines configurations de PAM.

L'ancienne distribution stable (Woody) n'est pas touchée par ce problème.

Pour l'actuelle distribution stable (Sarge), ce problème a été corrigé dans la version 2.4.3-20050321+2sarge1.

Pour la distribution instable (Sid), ce problème a été corrigé dans la version 2.4.4rel-1.

Nous vous recommandons de mettre à jour votre paquet ppp.

Corrigé dans :

Debian GNU/Linux 3.1 (sarge)

Source :
http://security.debian.org/pool/updates/main/p/ppp/ppp_2.4.3-20050321+2sarge1.dsc
http://security.debian.org/pool/updates/main/p/ppp/ppp_2.4.3-20050321+2sarge1.diff.gz
http://security.debian.org/pool/updates/main/p/ppp/ppp_2.4.3.orig.tar.gz
Composant indépendant de l'architecture :
http://security.debian.org/pool/updates/main/p/ppp/ppp-dev_2.4.3-20050321+2sarge1_all.deb
Alpha:
http://security.debian.org/pool/updates/main/p/ppp/ppp_2.4.3-20050321+2sarge1_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/p/ppp/ppp_2.4.3-20050321+2sarge1_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/p/ppp/ppp_2.4.3-20050321+2sarge1_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/p/ppp/ppp_2.4.3-20050321+2sarge1_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/p/ppp/ppp_2.4.3-20050321+2sarge1_ia64.deb
HPPA:
http://security.debian.org/pool/updates/main/p/ppp/ppp_2.4.3-20050321+2sarge1_hppa.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/p/ppp/ppp_2.4.3-20050321+2sarge1_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/p/ppp/ppp_2.4.3-20050321+2sarge1_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/p/ppp/ppp_2.4.3-20050321+2sarge1_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/p/ppp/ppp_2.4.3-20050321+2sarge1_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/p/ppp/ppp_2.4.3-20050321+2sarge1_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/p/ppp/ppp_2.4.3-20050321+2sarge1_sparc.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.