Debian-Sicherheitsankündigung

DSA-1109-1 rssh -- Programmierfehler

Datum des Berichts:
16. Jul 2006
Betroffene Pakete:
rssh
Verwundbar:
Ja
Sicherheitsdatenbanken-Referenzen:
In der Debian-Fehlerdatenbank: Fehler 346322.
In Mitres CVE-Verzeichnis: CVE-2006-1320.
Weitere Informationen:

Russ Allbery entdeckte, dass rssh, eine limitierte Shell, eine unzureichende Überprüfung von eintreffenden Befehlen durchführt, was die Umgehung von Zugriffsbeschränkungen zur Folge haben könnte.

Für die Stable-Distribution (Sarge) wurde dieses Problem in Version 2.2.3-1.sarge.2 behoben.

Für die Unstable-Distribution (Sid) wurde dieses Problem in Version 2.3.0-1.1 behoben.

Wir empfehlen Ihnen, Ihr rssh-Paket zu aktualisieren.

Behoben in:

Debian GNU/Linux 3.1 (sarge)

Quellcode:
http://security.debian.org/pool/updates/main/r/rssh/rssh_2.2.3-1.sarge.2.dsc
http://security.debian.org/pool/updates/main/r/rssh/rssh_2.2.3-1.sarge.2.diff.gz
http://security.debian.org/pool/updates/main/r/rssh/rssh_2.2.3.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/r/rssh/rssh_2.2.3-1.sarge.2_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/r/rssh/rssh_2.2.3-1.sarge.2_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/r/rssh/rssh_2.2.3-1.sarge.2_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/r/rssh/rssh_2.2.3-1.sarge.2_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/r/rssh/rssh_2.2.3-1.sarge.2_ia64.deb
HPPA:
http://security.debian.org/pool/updates/main/r/rssh/rssh_2.2.3-1.sarge.2_hppa.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/r/rssh/rssh_2.2.3-1.sarge.2_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/r/rssh/rssh_2.2.3-1.sarge.2_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/r/rssh/rssh_2.2.3-1.sarge.2_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/r/rssh/rssh_2.2.3-1.sarge.2_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/r/rssh/rssh_2.2.3-1.sarge.2_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/r/rssh/rssh_2.2.3-1.sarge.2_sparc.deb

MD5-Prüfsummen der aufgeführten Dateien stehen in der ursprünglichen Sicherheitsankündigung zur Verfügung.