Bulletin d'alerte Debian

DSA-1109-1 rssh -- Erreur de programmation

Date du rapport :
16 juillet 2006
Paquets concernés :
rssh
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 346322.
Dans le dictionnaire CVE du Mitre : CVE-2006-1320.
Plus de précisions :

Russ Allbery a découvert que rssh, un interpréteur de commandes restreint, n'effectuait pas de vérifications suffisantes des commandes entrantes, ce qui pouvait permettre le contournement de restrictions d'accès.

Pour l'actuelle distribution stable (Sarge), ce problème a été corrigé dans la version 2.2.3-1.sarge.2.

Pour la distribution instable (Sid), ce problème a été corrigé dans la version 2.3.0-1.1.

Nous vous recommandons de mettre à jour votre paquet rssh.

Corrigé dans :

Debian GNU/Linux 3.1 (sarge)

Source :
http://security.debian.org/pool/updates/main/r/rssh/rssh_2.2.3-1.sarge.2.dsc
http://security.debian.org/pool/updates/main/r/rssh/rssh_2.2.3-1.sarge.2.diff.gz
http://security.debian.org/pool/updates/main/r/rssh/rssh_2.2.3.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/r/rssh/rssh_2.2.3-1.sarge.2_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/r/rssh/rssh_2.2.3-1.sarge.2_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/r/rssh/rssh_2.2.3-1.sarge.2_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/r/rssh/rssh_2.2.3-1.sarge.2_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/r/rssh/rssh_2.2.3-1.sarge.2_ia64.deb
HPPA:
http://security.debian.org/pool/updates/main/r/rssh/rssh_2.2.3-1.sarge.2_hppa.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/r/rssh/rssh_2.2.3-1.sarge.2_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/r/rssh/rssh_2.2.3-1.sarge.2_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/r/rssh/rssh_2.2.3-1.sarge.2_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/r/rssh/rssh_2.2.3-1.sarge.2_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/r/rssh/rssh_2.2.3-1.sarge.2_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/r/rssh/rssh_2.2.3-1.sarge.2_sparc.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.