Debian Security Advisory

DSA-1116-1 gimp -- buffer overflow

Date Reported:
21 Jul 2006
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2006-3404.
More information:

Henning Makholm discovered a buffer overflow in the XCF loading code of Gimp, an image editing program. Opening a specially crafted XCF image might cause the application to execute arbitrary code.

For the stable distribution (sarge) this problem has been fixed in version 2.2.6-1sarge1.

For the unstable distribution (sid) this problem has been fixed in version 2.2.11-3.1.

We recommend that you upgrade your gimp package.

Fixed in:

Debian GNU/Linux 3.1 alias sarge

Architecture-independent component:
Alpha architecture:
AMD64 architecture:
ARM architecture:
Intel IA-32 architecture:
Intel IA-64 architecture:
HP Precision architecture:
Motorola 680x0 architecture:
Big endian MIPS architecture:
Little endian MIPS architecture:
PowerPC architecture:
IBM S/390 architecture:
Sun Sparc architecture:

MD5 checksums of the listed files are available in the original advisory.