Debian-Sicherheitsankündigung

DSA-1119-1 hiki -- Designschwäche

Datum des Berichts:
22. Jul 2006
Betroffene Pakete:
hiki
Verwundbar:
Ja
Sicherheitsdatenbanken-Referenzen:
In der Debian-Fehlerdatenbank: Fehler 378059.
In der Bugtraq-Datenbank (bei SecurityFocus): BugTraq ID 18785.
In Mitres CVE-Verzeichnis: CVE-2006-3379.
Weitere Informationen:

Akira Tanaka entdeckte eine Verwundbarkeit in Hiki Wiki, einer in Ruby geschriebenen Wiki-Engine, die es entfernten Angreifern ermöglicht, eine Diensteverweigerung (denial of service) zu verursachen, indem beim Vergleich von großen und speziell erstellten Wiki-Seiten hohe CPU-Leistung beansprucht wird.

Für die Stable-Distribution (Sarge) wurde dieses Problem in Version 0.6.5-2 behoben.

Für die Unstable-Distribution (Sid) wurde dieses Problem in Version 0.8.6-1 behoben.

Wir empfehlen Ihnen, Ihr hiki-Paket zu aktualisieren.

Behoben in:

Debian GNU/Linux 3.1 (sarge)

Quellcode:
http://security.debian.org/pool/updates/main/h/hiki/hiki_0.6.5-2.dsc
http://security.debian.org/pool/updates/main/h/hiki/hiki_0.6.5-2.diff.gz
http://security.debian.org/pool/updates/main/h/hiki/hiki_0.6.5.orig.tar.gz
Architektur-unabhängige Dateien:
http://security.debian.org/pool/updates/main/h/hiki/hiki_0.6.5-2_all.deb

MD5-Prüfsummen der aufgeführten Dateien stehen in der ursprünglichen Sicherheitsankündigung zur Verfügung.