Aviso de seguridad de Debian

DSA-1119-1 hiki -- debilidad de diseño

Fecha del informe:
22 de jul de 2006
Paquetes afectados:
hiki
Vulnerable:
Referencias a bases de datos de seguridad:
En el sistema de seguimiento de errores de Debian: error 378059.
En la base de datos de Bugtraq (en SecurityFocus): Id. en BugTraq 18785.
En el diccionario CVE de Mitre: CVE-2006-3379.
Información adicional:

Akira Tanaka descubrió una vulnerabilidad en Hiki Wiki, un motor de Wiki escrito en Ruby que permitía que los atacantes remotos provocasen una denegación de servicio por altos consumos de CPU, al realizar la búsqueda de diferencias entre páginas de Wiki grandes y perniciosas.

Para la distribución estable (sarge), este problema se ha corregido en la versión 0.6.5-2.

Para la distribución inestable (sid), este problema se ha corregido en la versión 0.8.6-1.

Le recomendamos que actualice el paquete hiki.

Arreglado en:

Debian GNU/Linux 3.1 (sarge)

Fuentes:
http://security.debian.org/pool/updates/main/h/hiki/hiki_0.6.5-2.dsc
http://security.debian.org/pool/updates/main/h/hiki/hiki_0.6.5-2.diff.gz
http://security.debian.org/pool/updates/main/h/hiki/hiki_0.6.5.orig.tar.gz
Componentes independientes de la arquitectura:
http://security.debian.org/pool/updates/main/h/hiki/hiki_0.6.5-2_all.deb

Las sumas MD5 de los ficheros que se listan están disponibles en el aviso original.