Debian セキュリティ勧告

DSA-1119-1 hiki -- デザイン上の欠陥

報告日時:
2006-07-22
影響を受けるパッケージ:
hiki
危険性:
あり
参考セキュリティデータベース:
Debian バグ追跡システム: バグ 378059.
(SecurityFocus の) Bugtraq データベース: BugTraq ID 18785.
Mitre の CVE 辞書: CVE-2006-3379.
詳細:

田中 哲さんにより、Ruby で書かれた Wiki エンジン Hiki Wiki に脆弱性が発見されました。リモートの攻撃者が、特殊な細工をした巨大な Wiki ページとの diff を実行させることにより、CPU を過大に消費させることでサービス不能 (DoS) 攻撃を引き起こさせます。

安定版ディストリビューション (stable、コードネーム sarge) では、この問題はバージョン 0.6.5-2 で修正されています。

不安定版ディストリビューション (unstable、コードネーム sid) では、この問題はバージョン 0.8.6-1 で修正されています。

hiki パッケージのアップグレードをお勧めします。

修正:

Debian GNU/Linux 3.1 (sarge)

ソース:
http://security.debian.org/pool/updates/main/h/hiki/hiki_0.6.5-2.dsc
http://security.debian.org/pool/updates/main/h/hiki/hiki_0.6.5-2.diff.gz
http://security.debian.org/pool/updates/main/h/hiki/hiki_0.6.5.orig.tar.gz
アーキテクチャ非依存コンポーネント:
http://security.debian.org/pool/updates/main/h/hiki/hiki_0.6.5-2_all.deb

一覧にあるファイルの MD5 チェックサムは勧告の原文にあります。