Bulletin d'alerte Debian

DSA-1121-1 postgrey -- Chaîne de formatage

Date du rapport :
24 juillet 2006
Paquets concernés :
postgrey
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2005-1127.
Plus de précisions :

Peter Bieringer a découvert que postgrey, une implémentation de listes grises (« greylisting ») pour Postfix, était vulnérable à une attaque distante par déni de service, en raison d'un problème de chaîne de formatage.

Pour l'actuelle distribution stable (Sarge), ce problème a été corrigé dans la version 1.21-1sarge1.

Pour l'actuelle distribution stable (Sarge), ce problème a été corrigé dans la version 1.21-1volatile4 de l'archive « volatile ».

Pour la distribution instable (Sid), ce problème a été corrigé dans la version 1.22-1.

Nous vous recommandons de mettre à jour votre paquet postgrey.

Corrigé dans :

Debian GNU/Linux 3.1 (sarge)

Source :
http://security.debian.org/pool/updates/main/p/postgrey/postgrey_1.21-1sarge1.dsc
http://security.debian.org/pool/updates/main/p/postgrey/postgrey_1.21-1sarge1.diff.gz
http://security.debian.org/pool/updates/main/p/postgrey/postgrey_1.21.orig.tar.gz
Composant indépendant de l'architecture :
http://security.debian.org/pool/updates/main/p/postgrey/postgrey_1.21-1sarge1_all.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.