Debians sikkerhedsbulletin

DSA-1122-1 libnet-server-perl -- formatstrengsårbarhed

Rapporteret den:
24. jul 2006
Berørte pakker:
libnet-server-perl
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Debians fejlsporingssystem: Fejl 378640.
I Mitres CVE-ordbog: CVE-2005-1127.
Yderligere oplysninger:

Peter Bieringer har opdaget at funktionen "log" i Perl-modulet Net::Server, en udvidbar generel Perl-servermaskine, ikke var sikker over for formatstrengudnyttelser.

Den gamle stabile distribution (woody) indeholder ikke denne pakke.

I den stabile distribution (sarge) er dette problem rettet i version 0.87-3sarge1.

I den ustabile distribution (sid) er dette problem rettet i version 0.89-1.

Vi anbefaler at du opgraderer din libnet-server-perl-pakke.

Rettet i:

Debian GNU/Linux 3.1 (sarge)

Kildekode:
http://security.debian.org/pool/updates/main/libn/libnet-server-perl/libnet-server-perl_0.87-3sarge1.dsc
http://security.debian.org/pool/updates/main/libn/libnet-server-perl/libnet-server-perl_0.87-3sarge1.diff.gz
http://security.debian.org/pool/updates/main/libn/libnet-server-perl/libnet-server-perl_0.87.orig.tar.gz
Arkitekturuafhængig komponent:
http://security.debian.org/pool/updates/main/libn/libnet-server-perl/libnet-server-perl_0.87-3sarge1_all.deb

MD5-kontrolsummer for de listede filer findes i den originale sikkerhedsbulletin.