Aviso de seguridad de Debian

DSA-1122-1 libnet-server-perl -- cadena de formato

Fecha del informe:
24 de jul de 2006
Paquetes afectados:
libnet-server-perl
Vulnerable:
Referencias a bases de datos de seguridad:
En el sistema de seguimiento de errores de Debian: error 378640.
En el diccionario CVE de Mitre: CVE-2005-1127.
Información adicional:

Peter Bieringer descubrió que la función «log» del módulo de Perl Net::Server, un motor para servidores escrito en Perl, no estaba protegido frente a vulnerabilidades de cadena de formato.

La distribución estable anterior (woody) no contiene este paquete.

Para la distribución estable (sarge), este problema se ha corregido en la versión 0.87-3sarge1.

Para la distribución inestable (sid), este problema se ha corregido en la versión 0.89-1.

Le recomendamos que actualice el paquete libnet-server-perl.

Arreglado en:

Debian GNU/Linux 3.1 (sarge)

Fuentes:
http://security.debian.org/pool/updates/main/libn/libnet-server-perl/libnet-server-perl_0.87-3sarge1.dsc
http://security.debian.org/pool/updates/main/libn/libnet-server-perl/libnet-server-perl_0.87-3sarge1.diff.gz
http://security.debian.org/pool/updates/main/libn/libnet-server-perl/libnet-server-perl_0.87.orig.tar.gz
Componentes independientes de la arquitectura:
http://security.debian.org/pool/updates/main/libn/libnet-server-perl/libnet-server-perl_0.87-3sarge1_all.deb

Las sumas MD5 de los ficheros que se listan están disponibles en el aviso original.