Säkerhetsbulletin från Debian

DSA-1122-1 libnet-server-perl -- formatsträng

Rapporterat den:
2006-07-24
Berörda paket:
libnet-server-perl
Sårbara:
Ja
Referenser i säkerhetsdatabaser:
I Debians felrapporteringssystem: Fel 378640.
I Mitres CVE-förteckning: CVE-2005-1127.
Ytterligare information:

Peter Bieringer upptäckte att log-funktionen i Perlmodulen Net::Server, en utökningsbar, generell Perlservermotor, inte var säker mot formatsträngsangrepp.

Den gamla stabila utgåvan (Woody) innehåller inte detta paket.

För den stabila utgåvan (Sarge) har detta problem rättats i version 0.87-3sarge1.

För den instabila utgåvan (Sid) har detta problem rättats i version 0.89-1.

Vi rekommenderar att ni uppgraderar ert libnet-server-perl-paket.

Rättat i:

Debian GNU/Linux 3.1 (sarge)

Källkod:
http://security.debian.org/pool/updates/main/libn/libnet-server-perl/libnet-server-perl_0.87-3sarge1.dsc
http://security.debian.org/pool/updates/main/libn/libnet-server-perl/libnet-server-perl_0.87-3sarge1.diff.gz
http://security.debian.org/pool/updates/main/libn/libnet-server-perl/libnet-server-perl_0.87.orig.tar.gz
Arkitekturoberoende komponent:
http://security.debian.org/pool/updates/main/libn/libnet-server-perl/libnet-server-perl_0.87-3sarge1_all.deb

MD5-kontrollsummor för dessa filer finns i originalbulletinen.