Debian Security Advisory

DSA-1130-1 sitebar -- missing input validation

Date Reported:
30 Jul 2006
Affected Packages:
Security database references:
In the Debian bugtracking system: Bug 377299.
In the Bugtraq database (at SecurityFocus): BugTraq ID 18680.
In Mitre's CVE dictionary: CVE-2006-3320.
More information:

A cross-site scripting vulnerability has been discovered in sitebar, a web based bookmark manager written in PHP, which allows remote attackers to inject arbitrary web script or HTML.

For the stable distribution (sarge) this problem has been fixed in version 3.2.6-7.1.

For the unstable distribution (sid) this problem has been fixed in version 3.3.8-1.1.

We recommend that you upgrade your sitebar package.

Fixed in:

Debian GNU/Linux 3.1 (sarge)

Architecture-independent component:

MD5 checksums of the listed files are available in the original advisory.