Debian-Sicherheitsankündigung

DSA-1149-1 ncompress -- Pufferunterlauf

Datum des Berichts:
10. Aug 2006
Betroffene Pakete:
ncompress
Verwundbar:
Ja
Sicherheitsdatenbanken-Referenzen:
In Mitres CVE-Verzeichnis: CVE-2006-1168.
Weitere Informationen:

Tavis Ormandy vom Google-Sicherheitsteam entdeckte eine fehlende Überprüfung der Grenzen in ncompress, dem ursprünglichen Lempel-Ziv-Komprimierungs- und -Dekomprimierungsprogrammen compress bzw. uncompress, was es einem speziell erzeugten Datenstrom erlaubt, einen Puffer mit vom Angreifer bestimmten Werten zu unterlaufen.

Für die Stable-Distribution (Sarge) wurde dieses Problem in Version 4.2.4-15sarge2 behoben.

Für die Unstable-Distribution (Sid) wurde dieses Problem in Version 4.2.4-15sarge2 behoben.

Wir empfehlen Ihnen, Ihr ncompress-Paket zu aktualisieren.

Behoben in:

Debian GNU/Linux 3.1 (sarge)

Quellcode:
http://security.debian.org/pool/updates/main/n/ncompress/ncompress_4.2.4-15sarge2.dsc
http://security.debian.org/pool/updates/main/n/ncompress/ncompress_4.2.4-15sarge2.diff.gz
http://security.debian.org/pool/updates/main/n/ncompress/ncompress_4.2.4.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/n/ncompress/ncompress_4.2.4-15sarge2_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/n/ncompress/ncompress_4.2.4-15sarge2_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/n/ncompress/ncompress_4.2.4-15sarge2_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/n/ncompress/ncompress_4.2.4-15sarge2_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/n/ncompress/ncompress_4.2.4-15sarge2_ia64.deb
HPPA:
http://security.debian.org/pool/updates/main/n/ncompress/ncompress_4.2.4-15sarge2_hppa.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/n/ncompress/ncompress_4.2.4-15sarge2_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/n/ncompress/ncompress_4.2.4-15sarge2_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/n/ncompress/ncompress_4.2.4-15sarge2_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/n/ncompress/ncompress_4.2.4-15sarge2_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/n/ncompress/ncompress_4.2.4-15sarge2_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/n/ncompress/ncompress_4.2.4-15sarge2_sparc.deb

MD5-Prüfsummen der aufgeführten Dateien stehen in der ursprünglichen Sicherheitsankündigung zur Verfügung.