Bulletin d'alerte Debian

DSA-1152-1 trac -- Vérification des entrées manquante

Date du rapport :
18 août 2006
Paquets concernés :
trac
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2006-3695.
Plus de précisions :

Felix Wiemann a découvert que trac, un wiki amélioré et un système de gestion des problèmes pour les projets de développement de logiciels, pouvait être utilisé pour divulguer des fichiers locaux arbitraires. Pour corriger ce problème, le paquet python-docutils a également besoin d'être mis à jour.

Pour la distribution stable (Sarge), ce problème a été corrigé dans la version 0.8.1-3sarge5 de trac et la version 0.3.7-2sarge1 de python-docutils.

Pour la distribution instable (Sid), ce problème a été corrigé dans la version 0.9.6-1.

Nous vous recommandons de mettre à jour vos paquets trac et python-docutils.

Corrigé dans :

Debian GNU/Linux 3.1 (sarge)

Source :
http://security.debian.org/pool/updates/main/p/python-docutils/python-docutils_0.3.7-2sarge1.dsc
http://security.debian.org/pool/updates/main/p/python-docutils/python-docutils_0.3.7-2sarge1.diff.gz
http://security.debian.org/pool/updates/main/p/python-docutils/python-docutils_0.3.7.orig.tar.gz
http://security.debian.org/pool/updates/main/t/trac/trac_0.8.1-3sarge5.dsc
http://security.debian.org/pool/updates/main/t/trac/trac_0.8.1-3sarge5.diff.gz
http://security.debian.org/pool/updates/main/t/trac/trac_0.8.1.orig.tar.gz
Composant indépendant de l'architecture :
http://security.debian.org/pool/updates/main/p/python-docutils/python-docutils_0.3.7-2sarge1_all.deb
http://security.debian.org/pool/updates/main/p/python-docutils/python-roman_0.3.7-2sarge1_all.deb
http://security.debian.org/pool/updates/main/p/python-docutils/python2.1-difflib_0.3.7-2sarge1_all.deb
http://security.debian.org/pool/updates/main/p/python-docutils/python2.1-textwrap_0.3.7-2sarge1_all.deb
http://security.debian.org/pool/updates/main/p/python-docutils/python2.2-docutils_0.3.7-2sarge1_all.deb
http://security.debian.org/pool/updates/main/p/python-docutils/python2.2-textwrap_0.3.7-2sarge1_all.deb
http://security.debian.org/pool/updates/main/p/python-docutils/python2.3-docutils_0.3.7-2sarge1_all.deb
http://security.debian.org/pool/updates/main/p/python-docutils/python2.4-docutils_0.3.7-2sarge1_all.deb
http://security.debian.org/pool/updates/main/t/trac/trac_0.8.1-3sarge5_all.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.