Aviso de seguridad de Debian

DSA-1154-1 squirrelmail -- sobreescritura de variable

Fecha del informe:
20 de ago de 2006
Paquetes afectados:
squirrelmail
Vulnerable:
Referencias a bases de datos de seguridad:
En el diccionario CVE de Mitre: CVE-2006-4019.
Información adicional:

James Bercegay, de GulfTech Security Research, descubrió una vulnerabilidad en Squirrelmail, mediante la cual un usuario autenticado podía sobreescribir variables aleatorias en el guión compose. Se podía sacar provecho de esto para leer o escribir las preferencias o los archivos adjuntos de otros usuarios.

Para la distribución estable (sarge), este problema se ha corregido en la versión 1.4.4-9.

Para la distribución inestable (sid), este problema se ha corregido en la versión 1.4.8-1.

Le recomendamos que actualice el paquete squirrelmail.

Arreglado en:

Debian GNU/Linux 3.1 (sarge)

Fuentes:
http://security.debian.org/pool/updates/main/s/squirrelmail/squirrelmail_1.4.4-9.dsc
http://security.debian.org/pool/updates/main/s/squirrelmail/squirrelmail_1.4.4-9.diff.gz
http://security.debian.org/pool/updates/main/s/squirrelmail/squirrelmail_1.4.4.orig.tar.gz
Componentes independientes de la arquitectura:
http://security.debian.org/pool/updates/main/s/squirrelmail/squirrelmail_1.4.4-9_all.deb

Las sumas MD5 de los ficheros que se listan están disponibles en el aviso original.