Debian Security Advisory

DSA-1157-1 ruby1.8 -- several vulnerabilities

Date Reported:
27 Aug 2006
Affected Packages:
Security database references:
In the Debian bugtracking system: Bug 378029, Bug 365520.
In Mitre's CVE dictionary: CVE-2006-3694, CVE-2006-1931.
More information:

Several vulnerabilities have been discovered in the interpreter for the Ruby language, which may lead to the bypass of security restrictions or denial of service. The Common Vulnerabilities and Exposures project identifies the following problems:

  • CVE-2006-1931

    It was discovered that the use of blocking sockets can lead to denial of service.

  • CVE-2006-3964

    It was discovered that Ruby does not properly maintain "safe levels" for aliasing, directory accesses and regular expressions, which might lead to a bypass of security restrictions.

For the stable distribution (sarge) these problems have been fixed in version 1.8.2-7sarge4.

For the unstable distribution (sid) these problems have been fixed in version 1.8.4-3.

We recommend that you upgrade your Ruby packages.

Fixed in:

Debian GNU/Linux 3.1 (sarge)

Architecture-independent component:
Intel IA-32:
Intel IA-64:
Motorola 680x0:
Big endian MIPS:
Little endian MIPS:
IBM S/390:
Sun Sparc:

MD5 checksums of the listed files are available in the original advisory.