Debian-Sicherheitsankündigung

DSA-1165-1 capi4hylafax -- Programmierfehler

Datum des Berichts:
01. Sep 2006
Betroffene Pakete:
capi4hylafax
Verwundbar:
Ja
Sicherheitsdatenbanken-Referenzen:
In Mitres CVE-Verzeichnis: CVE-2006-3126.
Weitere Informationen:

Lionel Elie Mamane entdeckte eine Sicherheitsverwundbarkeit in capi4hylafax, Werkzeugen für das Faxen über ein CAPI 2.0-Gerät, was es entfernten Angreifern erlaubt, beliebige Kommandos auf dem System, das die Faxe empfängt, auszuführen.

Für die Stable-Distribution (Sarge) wurde dieses Problem in Version 01.02.03-10sarge2 behoben.

Für die Unstable-Distribution (Sid) wurde dieses Problem in Version 01.03.00.99.svn.300-3 behoben.

Wir empfehlen Ihnen, Ihr capi4hylafax-Paket zu aktualisieren.

Behoben in:

Debian GNU/Linux 3.1 (sarge)

Quellcode:
http://security.debian.org/pool/updates/main/c/capi4hylafax/capi4hylafax_01.02.03-10sarge2.dsc
http://security.debian.org/pool/updates/main/c/capi4hylafax/capi4hylafax_01.02.03-10sarge2.diff.gz
http://security.debian.org/pool/updates/main/c/capi4hylafax/capi4hylafax_01.02.03.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/c/capi4hylafax/capi4hylafax_01.02.03-10sarge2_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/c/capi4hylafax/capi4hylafax_01.02.03-10sarge2_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/c/capi4hylafax/capi4hylafax_01.02.03-10sarge2_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/c/capi4hylafax/capi4hylafax_01.02.03-10sarge2_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/c/capi4hylafax/capi4hylafax_01.02.03-10sarge2_ia64.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/c/capi4hylafax/capi4hylafax_01.02.03-10sarge2_m68k.deb
PowerPC:
http://security.debian.org/pool/updates/main/c/capi4hylafax/capi4hylafax_01.02.03-10sarge2_powerpc.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/c/capi4hylafax/capi4hylafax_01.02.03-10sarge2_sparc.deb

MD5-Prüfsummen der aufgeführten Dateien stehen in der ursprünglichen Sicherheitsankündigung zur Verfügung.