Bulletin d'alerte Debian

DSA-1176-1 zope2.7 -- Erreur de programmation

Date du rapport :
13 septembre 2006
Paquets concernés :
zope2.7
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2006-4684.
Plus de précisions :

On a découvert que le serveur d'application web Zope ne désactivait pas la directive csv_table dans les pages contenant la balise ReST, cela permet l'exposition de fichiers accessibles en lecture par le serveur Zope.

Pour la distribution stable (Sarge), ce problème a été corrigé dans la version 2.7.5-2sarge2.

La distribution instable (Sid) ne contient plus le paquet zope2.7, pour zope2.8, ce problème a été corrigé dans la version 2.8.8-2.

Nous vous recommandons de mettre à jour votre paquet Zope.

Corrigé dans :

Debian GNU/Linux 3.1 (sarge)

Source :
http://security.debian.org/pool/updates/main/z/zope2.7/zope2.7_2.7.5-2sarge3.dsc
http://security.debian.org/pool/updates/main/z/zope2.7/zope2.7_2.7.5-2sarge3.diff.gz
http://security.debian.org/pool/updates/main/z/zope2.7/zope2.7_2.7.5.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/z/zope2.7/zope2.7_2.7.5-2sarge3_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/z/zope2.7/zope2.7_2.7.5-2sarge3_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/z/zope2.7/zope2.7_2.7.5-2sarge3_arm.deb
HPPA:
http://security.debian.org/pool/updates/main/z/zope2.7/zope2.7_2.7.5-2sarge3_hppa.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/z/zope2.7/zope2.7_2.7.5-2sarge3_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/z/zope2.7/zope2.7_2.7.5-2sarge3_ia64.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/z/zope2.7/zope2.7_2.7.5-2sarge3_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/z/zope2.7/zope2.7_2.7.5-2sarge3_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/z/zope2.7/zope2.7_2.7.5-2sarge3_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/z/zope2.7/zope2.7_2.7.5-2sarge3_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/z/zope2.7/zope2.7_2.7.5-2sarge3_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/z/zope2.7/zope2.7_2.7.5-2sarge3_sparc.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.