Bulletin d'alerte Debian

DSA-1194-1 libwmf -- Dépassement d'entier

Date du rapport :
9 octobre 2006
Paquets concernés :
libwmf
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 381538.
Dans le dictionnaire CVE du Mitre : CVE-2006-3376.
Plus de précisions :

On a découvert qu'un dépassement d'entier dans libwmf, la bibliothèque de lecture des fichiers Windows Metafile Format, pouvait être exploité pour exécuter un code arbitraire si un fichier WMF conçu spécialement était analysé.

Pour la distribution stable (Sarge), ce problème a été corrigé dans la version 0.2.8.3-2sarge1.

Pour la distribution instable (Sid), ce problème a été corrigé dans la version 0.2.8.4-2.

Nous vous recommandons de mettre à jour votre paquet libwmf.

Corrigé dans :

Debian GNU/Linux 3.1 (sarge)

Source :
http://security.debian.org/pool/updates/main/libw/libwmf/libwmf_0.2.8.3-2sarge1.dsc
http://security.debian.org/pool/updates/main/libw/libwmf/libwmf_0.2.8.3-2sarge1.diff.gz
http://security.debian.org/pool/updates/main/libw/libwmf/libwmf_0.2.8.3.orig.tar.gz
Composant indépendant de l'architecture :
http://security.debian.org/pool/updates/main/libw/libwmf/libwmf-doc_0.2.8.3-2sarge1_all.deb
Alpha:
http://security.debian.org/pool/updates/main/libw/libwmf/libwmf-bin_0.2.8.3-2sarge1_alpha.deb
http://security.debian.org/pool/updates/main/libw/libwmf/libwmf-dev_0.2.8.3-2sarge1_alpha.deb
http://security.debian.org/pool/updates/main/libw/libwmf/libwmf0.2-7_0.2.8.3-2sarge1_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/libw/libwmf/libwmf-bin_0.2.8.3-2sarge1_amd64.deb
http://security.debian.org/pool/updates/main/libw/libwmf/libwmf-dev_0.2.8.3-2sarge1_amd64.deb
http://security.debian.org/pool/updates/main/libw/libwmf/libwmf0.2-7_0.2.8.3-2sarge1_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/libw/libwmf/libwmf-bin_0.2.8.3-2sarge1_arm.deb
http://security.debian.org/pool/updates/main/libw/libwmf/libwmf-dev_0.2.8.3-2sarge1_arm.deb
http://security.debian.org/pool/updates/main/libw/libwmf/libwmf0.2-7_0.2.8.3-2sarge1_arm.deb
HPPA:
http://security.debian.org/pool/updates/main/libw/libwmf/libwmf-bin_0.2.8.3-2sarge1_hppa.deb
http://security.debian.org/pool/updates/main/libw/libwmf/libwmf-dev_0.2.8.3-2sarge1_hppa.deb
http://security.debian.org/pool/updates/main/libw/libwmf/libwmf0.2-7_0.2.8.3-2sarge1_hppa.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/libw/libwmf/libwmf-bin_0.2.8.3-2sarge1_i386.deb
http://security.debian.org/pool/updates/main/libw/libwmf/libwmf-dev_0.2.8.3-2sarge1_i386.deb
http://security.debian.org/pool/updates/main/libw/libwmf/libwmf0.2-7_0.2.8.3-2sarge1_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/libw/libwmf/libwmf-bin_0.2.8.3-2sarge1_ia64.deb
http://security.debian.org/pool/updates/main/libw/libwmf/libwmf-dev_0.2.8.3-2sarge1_ia64.deb
http://security.debian.org/pool/updates/main/libw/libwmf/libwmf0.2-7_0.2.8.3-2sarge1_ia64.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/libw/libwmf/libwmf-bin_0.2.8.3-2sarge1_m68k.deb
http://security.debian.org/pool/updates/main/libw/libwmf/libwmf-dev_0.2.8.3-2sarge1_m68k.deb
http://security.debian.org/pool/updates/main/libw/libwmf/libwmf0.2-7_0.2.8.3-2sarge1_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/libw/libwmf/libwmf-bin_0.2.8.3-2sarge1_mips.deb
http://security.debian.org/pool/updates/main/libw/libwmf/libwmf-dev_0.2.8.3-2sarge1_mips.deb
http://security.debian.org/pool/updates/main/libw/libwmf/libwmf0.2-7_0.2.8.3-2sarge1_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/libw/libwmf/libwmf-bin_0.2.8.3-2sarge1_mipsel.deb
http://security.debian.org/pool/updates/main/libw/libwmf/libwmf-dev_0.2.8.3-2sarge1_mipsel.deb
http://security.debian.org/pool/updates/main/libw/libwmf/libwmf0.2-7_0.2.8.3-2sarge1_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/libw/libwmf/libwmf-bin_0.2.8.3-2sarge1_powerpc.deb
http://security.debian.org/pool/updates/main/libw/libwmf/libwmf-dev_0.2.8.3-2sarge1_powerpc.deb
http://security.debian.org/pool/updates/main/libw/libwmf/libwmf0.2-7_0.2.8.3-2sarge1_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/libw/libwmf/libwmf-bin_0.2.8.3-2sarge1_s390.deb
http://security.debian.org/pool/updates/main/libw/libwmf/libwmf-dev_0.2.8.3-2sarge1_s390.deb
http://security.debian.org/pool/updates/main/libw/libwmf/libwmf0.2-7_0.2.8.3-2sarge1_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/libw/libwmf/libwmf-bin_0.2.8.3-2sarge1_sparc.deb
http://security.debian.org/pool/updates/main/libw/libwmf/libwmf-dev_0.2.8.3-2sarge1_sparc.deb
http://security.debian.org/pool/updates/main/libw/libwmf/libwmf0.2-7_0.2.8.3-2sarge1_sparc.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.