Bulletin d'alerte Debian

DSA-1203-1 libpam-ldap -- Erreur de programmation

Date du rapport :
2 novembre 2006
Paquets concernés :
libpam-ldap
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 392984.
Dans le dictionnaire CVE du Mitre : CVE-2006-5170.
Plus de précisions :

Steve Rigler a découvert que le module PAM d'authentification sur le serveurs LDAP traitait les messages de contrôle PasswordPolicyReponse de manière incorrecte, cela peut conduire un attaquant à pouvoir se connecter sur un compte système suspendu.

Pour la distribution stable (Sarge), ce problème a été corrigé dans la version 178-1sarge3. À cause de problèmes techniques avec l'infrastructure des démons de construction de sécurité, cette mise à jour n'est pas disponible pour l'architecture Sun Sparc. Elle sera publiée dès que ces problèmes auront été résolus.

Pour la distribution instable (Sid), ce problème a été corrigé dans la versions 180-1.2.

Nous vous recommandons de mettre à jour votre paquet libpam-ldap.

Corrigé dans :

Debian GNU/Linux 3.1 (sarge)

Source :
http://security.debian.org/pool/updates/main/libp/libpam-ldap/libpam-ldap_178-1sarge3.dsc
http://security.debian.org/pool/updates/main/libp/libpam-ldap/libpam-ldap_178-1sarge3.diff.gz
http://security.debian.org/pool/updates/main/libp/libpam-ldap/libpam-ldap_178.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/libp/libpam-ldap/libpam-ldap_178-1sarge3_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/libp/libpam-ldap/libpam-ldap_178-1sarge3_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/libp/libpam-ldap/libpam-ldap_178-1sarge3_arm.deb
HPPA:
http://security.debian.org/pool/updates/main/libp/libpam-ldap/libpam-ldap_178-1sarge3_hppa.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/libp/libpam-ldap/libpam-ldap_178-1sarge3_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/libp/libpam-ldap/libpam-ldap_178-1sarge3_ia64.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/libp/libpam-ldap/libpam-ldap_178-1sarge3_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/libp/libpam-ldap/libpam-ldap_178-1sarge3_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/libp/libpam-ldap/libpam-ldap_178-1sarge3_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/libp/libpam-ldap/libpam-ldap_178-1sarge3_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/libp/libpam-ldap/libpam-ldap_178-1sarge3_s390.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.