Debian Security Advisory

DSA-1219-1 texinfo -- buffer overflow

Date Reported:
27 Nov 2006
Affected Packages:
Security database references:
In the Bugtraq database (at SecurityFocus): BugTraq ID 14854, BugTraq ID 20959.
In Mitre's CVE dictionary: CVE-2005-3011, CVE-2006-4810.
More information:

Multiple vulnerabilities have been found in the GNU texinfo package, a documentation system for on-line information and printed output.

  • CVE-2005-3011

    Handling of temporary files is performed in an insecure manner, allowing an attacker to overwrite any file writable by the victim.

  • CVE-2006-4810

    A buffer overflow in util/texindex.c could allow an attacker to execute arbitrary code with the victim's access rights by inducing the victim to run texindex or tex2dvi on a specially crafted texinfo file.

For the stable distribution (sarge), these problems have been fixed in version 4.7-2.2sarge2. Note that binary packages for the mipsel architecture are not currently available due to technical problems with the build host. These packages will be made available as soon as possible.

For unstable (sid) and the upcoming stable release (etch), these problems have been fixed in version 4.8.dfsg.1-4.

We recommend that you upgrade your texinfo package.

Fixed in:

Debian GNU/Linux 3.1 (sarge)

Intel IA-32:
Intel IA-64:
Motorola 680x0:
Big endian MIPS:
IBM S/390:
Sun Sparc:

MD5 checksums of the listed files are available in the original advisory.