Bulletin d'alerte Debian

DSA-1226-1 links -- Protection insuffisante

Date du rapport :
3 décembre 2006
Paquets concernés :
links
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 399187.
Dans le dictionnaire CVE du Mitre : CVE-2006-5925.
Plus de précisions :

Teemu Salmela a découvert que le navigateur en mode caractère links n'effectuait pas de vérifications suffisantes des URI smb://, cela peut conduire à l'exécution de commandes de shell arbitraires.

Pour la distribution stable (Sarge), ce problème a été corrigé dans la version 0.99+1.00pre12-1sarge1.

Pour la prochaine distribution stable (Etch), ce problème a été corrigé dans la versions 0.99+1.00pre12-1.1.

Pour la distribution instable (Sid), ce problème a été corrigé dans la versions 0.99+1.00pre12-1.1.

Nous vous recommandons de mettre à jour votre paquet links.

Corrigé dans :

Debian GNU/Linux 3.1 (sarge)

Source :
http://security.debian.org/pool/updates/main/l/links/links_0.99+1.00pre12-1sarge1.dsc
http://security.debian.org/pool/updates/main/l/links/links_0.99+1.00pre12-1sarge1.diff.gz
http://security.debian.org/pool/updates/main/l/links/links_0.99+1.00pre12.orig.tar.gz
Composant indépendant de l'architecture :
http://security.debian.org/pool/updates/main/l/links/links-ssl_0.99+1.00pre12-1sarge1_all.deb
Alpha:
http://security.debian.org/pool/updates/main/l/links/links_0.99+1.00pre12-1sarge1_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/l/links/links_0.99+1.00pre12-1sarge1_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/l/links/links_0.99+1.00pre12-1sarge1_arm.deb
HPPA:
http://security.debian.org/pool/updates/main/l/links/links_0.99+1.00pre12-1sarge1_hppa.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/l/links/links_0.99+1.00pre12-1sarge1_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/l/links/links_0.99+1.00pre12-1sarge1_ia64.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/l/links/links_0.99+1.00pre12-1sarge1_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/l/links/links_0.99+1.00pre12-1sarge1_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/l/links/links_0.99+1.00pre12-1sarge1_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/l/links/links_0.99+1.00pre12-1sarge1_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/l/links/links_0.99+1.00pre12-1sarge1_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/l/links/links_0.99+1.00pre12-1sarge1_sparc.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.