Debian-Sicherheitsankündigung

DSA-1228-1 elinks -- Unzureichendes Escaping

Datum des Berichts:
05. Dez 2006
Betroffene Pakete:
elinks
Verwundbar:
Ja
Sicherheitsdatenbanken-Referenzen:
In der Debian-Fehlerdatenbank: Fehler 399188.
In Mitres CVE-Verzeichnis: CVE-2006-5925.
Weitere Informationen:

Teemu Salmela entdeckte, dass der textbasierte Web-Browser elinks eine unzureichende Bereinigung von smb://-URIs durchführt, was zur Ausführung beliebiger Shell-Kommandos führen kann.

Für die Stable-Distribution (Sarge) wurde dieses Problem in Version 0.10.4-7.1 behoben.

Für die kommende Stable-Distribution (Etch) wurde dieses Problem in Version 0.11.1-1.2 behoben.

Für die Unstable-Distribution (Sid) wurde dieses Problem in Version 0.11.1-1.2 behoben.

Wir empfehlen Ihnen, Ihr elinks-Paket zu aktualisieren.

Behoben in:

Debian GNU/Linux 3.1 (sarge)

Quellcode:
http://security.debian.org/pool/updates/main/e/elinks/elinks_0.10.4-7.1.dsc
http://security.debian.org/pool/updates/main/e/elinks/elinks_0.10.4-7.1.diff.gz
http://security.debian.org/pool/updates/main/e/elinks/elinks_0.10.4.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/e/elinks/elinks_0.10.4-7.1_alpha.deb
http://security.debian.org/pool/updates/main/e/elinks/elinks-lite_0.10.4-7.1_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/e/elinks/elinks_0.10.4-7.1_amd64.deb
http://security.debian.org/pool/updates/main/e/elinks/elinks-lite_0.10.4-7.1_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/e/elinks/elinks_0.10.4-7.1_arm.deb
http://security.debian.org/pool/updates/main/e/elinks/elinks-lite_0.10.4-7.1_arm.deb
HPPA:
http://security.debian.org/pool/updates/main/e/elinks/elinks_0.10.4-7.1_hppa.deb
http://security.debian.org/pool/updates/main/e/elinks/elinks-lite_0.10.4-7.1_hppa.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/e/elinks/elinks_0.10.4-7.1_i386.deb
http://security.debian.org/pool/updates/main/e/elinks/elinks-lite_0.10.4-7.1_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/e/elinks/elinks_0.10.4-7.1_ia64.deb
http://security.debian.org/pool/updates/main/e/elinks/elinks-lite_0.10.4-7.1_ia64.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/e/elinks/elinks_0.10.4-7.1_m68k.deb
http://security.debian.org/pool/updates/main/e/elinks/elinks-lite_0.10.4-7.1_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/e/elinks/elinks_0.10.4-7.1_mips.deb
http://security.debian.org/pool/updates/main/e/elinks/elinks-lite_0.10.4-7.1_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/e/elinks/elinks_0.10.4-7.1_mipsel.deb
http://security.debian.org/pool/updates/main/e/elinks/elinks-lite_0.10.4-7.1_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/e/elinks/elinks_0.10.4-7.1_powerpc.deb
http://security.debian.org/pool/updates/main/e/elinks/elinks-lite_0.10.4-7.1_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/e/elinks/elinks_0.10.4-7.1_s390.deb
http://security.debian.org/pool/updates/main/e/elinks/elinks-lite_0.10.4-7.1_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/e/elinks/elinks_0.10.4-7.1_sparc.deb
http://security.debian.org/pool/updates/main/e/elinks/elinks-lite_0.10.4-7.1_sparc.deb

MD5-Prüfsummen der aufgeführten Dateien stehen in der ursprünglichen Sicherheitsankündigung zur Verfügung.