Bulletin d'alerte Debian

DSA-1230-1 l2tpns -- Débordement de mémoire tampon

Date du rapport :
8 décembre 2006
Paquets concernés :
l2tpns
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 401742.
Dans le dictionnaire CVE du Mitre : CVE-2006-5873.
Plus de précisions :

Rhys Kidd a découvert une vulnérabilité dans l2tpns, un serveur réseau de protocole de niveau 2 pour les tunnels, celle-ci pouvait être déclenchée par un utilisateur distant pour exécuter du code arbitraire.

Pour la distribution stable (Sarge), ce problème a été corrigé dans la version 2.0.14-1sarge1.

Pour la distribution instable (Sid), ce problème a été corrigé dans la versions 2.1.21-1.

Nous vous recommandons de mettre à jour votre paquet l2tpns.

Corrigé dans :

Debian GNU/Linux 3.1 (sarge)

Source :
http://security.debian.org/pool/updates/main/l/l2tpns/l2tpns_2.0.14-1sarge1.dsc
http://security.debian.org/pool/updates/main/l/l2tpns/l2tpns_2.0.14-1sarge1.diff.gz
http://security.debian.org/pool/updates/main/l/l2tpns/l2tpns_2.0.14.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/l/l2tpns/l2tpns_2.0.14-1sarge1_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/l/l2tpns/l2tpns_2.0.14-1sarge1_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/l/l2tpns/l2tpns_2.0.14-1sarge1_arm.deb
HPPA:
http://security.debian.org/pool/updates/main/l/l2tpns/l2tpns_2.0.14-1sarge1_hppa.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/l/l2tpns/l2tpns_2.0.14-1sarge1_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/l/l2tpns/l2tpns_2.0.14-1sarge1_ia64.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/l/l2tpns/l2tpns_2.0.14-1sarge1_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/l/l2tpns/l2tpns_2.0.14-1sarge1_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/l/l2tpns/l2tpns_2.0.14-1sarge1_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/l/l2tpns/l2tpns_2.0.14-1sarge1_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/l/l2tpns/l2tpns_2.0.14-1sarge1_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/l/l2tpns/l2tpns_2.0.14-1sarge1_sparc.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.