Debian Security Advisory

DSA-942-1 albatross -- design error

Date Reported:
16 Jan 2006
Affected Packages:
Security database references:
In the Bugtraq database (at SecurityFocus): BugTraq ID 16252.
In Mitre's CVE dictionary: CVE-2006-0044.
More information:

A design error has been discovered in the Albatross web application toolkit that causes user supplied data to be used as part of template execution and hence arbitrary code execution.

The old stable distribution (woody) does not contain albatross packages.

For the stable distribution (sarge) this problem has been fixed in version 1.20-2.

For the unstable distribution (sid) this problem has been fixed in version 1.33-1.

We recommend that you upgrade your albatross package.

Fixed in:

Debian GNU/Linux 3.1 (sarge)

Architecture-independent component:

MD5 checksums of the listed files are available in the original advisory.