Debians sikkerhedsbulletin

DSA-953-1 flyspray -- manglende kontrol af inddata

Rapporteret den:
24. jan 2006
Berørte pakker:
flyspray
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Debians fejlsporingssystem: Fejl 335997.
I Mitres CVE-ordbog: CVE-2005-3334.
Yderligere oplysninger:

Flere sårbarheder i forbindelse med udførelse af skripter på tværs af websteder (cross-site scripting) er fundet i flyspray, et letanvendeligt fejlsporingssystem. Sårbarhederne gjorde det muligt for angribere at indsætte vilkårlig skriptkode på index-siden.

Den gamle stabile distribution (woody) indeholder ikke flyspray.

I den stabile distribution (sarge) er dette problem rettet i version 0.9.7-2.1.

I distributionerne testing (etch) og unstable (sid) er dette problem rettet i version 0.9.8-5.

Vi anbefaler at du opgraderer din flyspray-pakke.

Rettet i:

Debian GNU/Linux 3.1 (sarge)

Kildekode:
http://security.debian.org/pool/updates/main/f/flyspray/flyspray_0.9.7-2.1.dsc
http://security.debian.org/pool/updates/main/f/flyspray/flyspray_0.9.7-2.1.diff.gz
http://security.debian.org/pool/updates/main/f/flyspray/flyspray_0.9.7.orig.tar.gz
Arkitekturuafhængig komponent:
http://security.debian.org/pool/updates/main/f/flyspray/flyspray_0.9.7-2.1_all.deb

MD5-kontrolsummer for de listede filer findes i den originale sikkerhedsbulletin.