Debian-Sicherheitsankündigung

DSA-953-1 flyspray -- Fehlende Eingabebereinigung

Datum des Berichts:
24. Jan 2006
Betroffene Pakete:
flyspray
Verwundbar:
Ja
Sicherheitsdatenbanken-Referenzen:
In der Debian-Fehlerdatenbank: Fehler 335997.
In Mitres CVE-Verzeichnis: CVE-2005-3334.
Weitere Informationen:

Mehrere Site-übergreifende Skripting-Verwundbarkeiten wurden in Flyspray, einer leichtgewichtigen Fehlerdatenbank, entdeckt, welche es Angreifern erlauben, beliebigen Skript-Code in die Index-Seite einzufügen.

Die alte Stable-Distribution (Woody) enthält das Flyspray-Paket nicht.

Für die Stable-Distribution (Sarge) wurde dieses Problem in Version 0.9.7-2.1 behoben.

Für die Unstable-Distribution (Sid) wurde dieses Problem in Version 0.9.8-5 behoben.

Wir empfehlen Ihnen, Ihr Flyspray-Paket zu aktualisieren.

Behoben in:

Debian GNU/Linux 3.1 (sarge)

Quellcode:
http://security.debian.org/pool/updates/main/f/flyspray/flyspray_0.9.7-2.1.dsc
http://security.debian.org/pool/updates/main/f/flyspray/flyspray_0.9.7-2.1.diff.gz
http://security.debian.org/pool/updates/main/f/flyspray/flyspray_0.9.7.orig.tar.gz
Architektur-unabhängige Dateien:
http://security.debian.org/pool/updates/main/f/flyspray/flyspray_0.9.7-2.1_all.deb

MD5-Prüfsummen der aufgeführten Dateien stehen in der ursprünglichen Sicherheitsankündigung zur Verfügung.