Debian Security Advisory

DSA-953-1 flyspray -- missing input sanitising

Date Reported:
24 Jan 2006
Affected Packages:
Security database references:
In the Debian bugtracking system: Bug 335997.
In Mitre's CVE dictionary: CVE-2005-3334.
More information:

Several cross-site scripting vulnerabilities have been discovered in flyspray, a lightweight bug tracking system, which allows attackers to insert arbitrary script code into the index page.

The old stable distribution (woody) does not contain flyspray.

For the stable distribution (sarge) this problem has been fixed in version 0.9.7-2.1.

For the testing (etch) and unstable distribution (sid) this problem has been fixed in version 0.9.8-5.

We recommend that you upgrade your flyspray package.

Fixed in:

Debian GNU/Linux 3.1 (sarge)

Architecture-independent component:

MD5 checksums of the listed files are available in the original advisory.