Bulletin d'alerte Debian

DSA-953-1 flyspray -- Mauvaise vérification des entrées

Date du rapport :
24 janvier 2006
Paquets concernés :
flyspray
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 335997.
Dans le dictionnaire CVE du Mitre : CVE-2005-3334.
Plus de précisions :

Plusieurs vulnérabilités de scripts intersites ont été découvertes dans flyspray, un système léger de suivi de bogues, qui permettaient à des attaquants d'insérer du code de script arbitraire dans la page d'index.

L'ancienne distribution stable (Woody) ne contient pas flyspray.

Pour l'actuelle distribution stable (Sarge), ce problème a été corrigé dans la version 0.9.7-2.1.

Pour la distribution de test (Etch) et la distribution instable (Sid), ce problème a été corrigé dans la version 0.9.8-5.

Nous vous recommandons de mettre à jour votre paquet flyspray.

Corrigé dans :

Debian GNU/Linux 3.1 (sarge)

Source :
http://security.debian.org/pool/updates/main/f/flyspray/flyspray_0.9.7-2.1.dsc
http://security.debian.org/pool/updates/main/f/flyspray/flyspray_0.9.7-2.1.diff.gz
http://security.debian.org/pool/updates/main/f/flyspray/flyspray_0.9.7.orig.tar.gz
Composant indépendant de l'architecture :
http://security.debian.org/pool/updates/main/f/flyspray/flyspray_0.9.7-2.1_all.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.