Debian Security Advisory

DSA-954-1 wine -- design flaw

Date Reported:
25 Jan 2006
Affected Packages:
Security database references:
In the Debian bugtracking system: Bug 346197.
In Mitre's CVE dictionary: CVE-2006-0106.
More information:

H D Moore has discovered that Wine, a free implementation of the Microsoft Windows APIs, inherits a design flaw from the Windows GDI API, which may lead to the execution of code through GDI escape functions in WMF files.

The old stable distribution (woody) does not seem to be affected by this problem.

For the stable distribution (sarge) this problem has been fixed in version 0.0.20050310-1.2.

For the unstable distribution (sid) this problem has been fixed in version 0.9.2-1.

We recommend that you upgrade your wine packages.

Fixed in:

Debian GNU/Linux 3.1 (sarge)

Architecture-independent component:
Intel IA-32:

MD5 checksums of the listed files are available in the original advisory.