Bulletin d'alerte Debian

DSA-970-1 kronolith -- Mauvaise vérification des entrées

Date du rapport :
14 février 2006
Paquets concernés :
kronolith
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 342943, Bogue 349261.
Dans le dictionnaire CVE du Mitre : CVE-2005-4189.
Plus de précisions :

Johannes Greil de SEC Consult a découvert plusieurs vulnérabilités de scripts intersites dans kronolith, l'application de calendrier pour Horde.

L'ancienne distribution stable (Woody) ne contient pas kronolith.

Pour l'actuelle distribution stable (Sarge), ces problèmes ont été corrigés dans la version 1.1.4-2sarge1.

Pour la distribution instable (Sid), ces problèmes ont été corrigés dans la version 2.0.6-1 de kronolith2.

Nous vous recommandons de mettre à jour vos paquets kronolith et kronolith2.

Corrigé dans :

Debian GNU/Linux 3.1 (sarge)

Source :
http://security.debian.org/pool/updates/main/k/kronolith/kronolith_1.1.4-2sarge1.dsc
http://security.debian.org/pool/updates/main/k/kronolith/kronolith_1.1.4-2sarge1.diff.gz
http://security.debian.org/pool/updates/main/k/kronolith/kronolith_1.1.4.orig.tar.gz
Composant indépendant de l'architecture :
http://security.debian.org/pool/updates/main/k/kronolith/kronolith_1.1.4-2sarge1_all.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.