Debian Security Advisory

DSA-977-1 heimdal -- several vulnerabilities

Date Reported:
16 Feb 2006
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2006-0582, CVE-2006-0677.
More information:

Two vulnerabilities have been discovered in heimdal, a free implementation of Kerberos 5. The Common Vulnerabilities and Exposures project identifies the following vulnerabilities:

  • CVE-2006-0582

    Privilege escalation in the rsh server allows an authenticated attacker to overwrite arbitrary files and gain ownership of them.

  • CVE-2006-0677

    A remote attacker could force the telnet server to crash before the user logged in, resulting in inetd turning telnetd off because it forked too fast.

The old stable distribution (woody) does not expose rsh and telnet servers.

For the stable distribution (sarge) these problems have been fixed in version 0.6.3-10sarge2.

For the unstable distribution (sid) these problems will be fixed soon.

We recommend that you upgrade your heimdal packages.

Fixed in:

Debian GNU/Linux 3.1 (sarge)

Architecture-independent component:
Intel IA-32:
Intel IA-64:
Motorola 680x0:
Big endian MIPS:
Little endian MIPS:
IBM S/390:
Sun Sparc:

MD5 checksums of the listed files are available in the original advisory.