Alerta de Segurança Debian

DSA-996-1 libcrypt-cbc-perl -- erro de programação

Data do Alerta:
13 Mar 2006
Pacotes Afetados:
libcrypt-cbc-perl
Vulnerável:
Sim
Referência à base de dados de segurança:
No dicionário CVE do Mitre: CVE-2006-0898.
Informações adicionais:

Lincoln Stein descobriu que o módulo Perl Crypt::CBC produz texto-cifrado fraco quando usado com algoritimos de criptografia de bloco com tamanho de bloco > 8 bytes.

A antiga distribuição estável ("woody") não contém o módulo Crypt::CBC.

Para a distribuição estável ("sarge") este problema foi corrigido na versão 2.12-1sarge1.

Para a distribuição instável ("sid") este problema foi corrigido na versão 2.17-1.

Recomendamos que você atualize seu pacote libcrypt-cbc-perl.

Corrigido em:

Debian GNU/Linux 3.1 (sarge)

Fonte:
http://security.debian.org/pool/updates/main/libc/libcrypt-cbc-perl/libcrypt-cbc-perl_2.12-1sarge1.dsc
http://security.debian.org/pool/updates/main/libc/libcrypt-cbc-perl/libcrypt-cbc-perl_2.12-1sarge1.diff.gz
http://security.debian.org/pool/updates/main/libc/libcrypt-cbc-perl/libcrypt-cbc-perl_2.12.orig.tar.gz
Componente independente de arquitetura:
http://security.debian.org/pool/updates/main/libc/libcrypt-cbc-perl/libcrypt-cbc-perl_2.12-1sarge1_all.deb

Checksums MD5 dos arquivos listados estão disponíveis no alerta original.