Bulletin d'alerte Debian

DSA-999-1 lurker -- Plusieurs vulnérabilités

Date du rapport :
14 mars 2006
Paquets concernés :
lurker
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2006-1062, CVE-2006-1063, CVE-2006-1064.
Plus de précisions :

Plusieurs vulnérabilités ont été découvertes dans lurker, un outil d'archivage de listes de diffusion avec moteur de recherche intégré. Le projet « Common Vulnerabilities and Exposures » a identifié les problèmes suivants :

  • CVE-2006-1062

    Dans lurker, le mécanisme pour spécifier les fichiers de configuration à utiliser pouvait être contourné. Comme lurker inclut dans sa sortie des sections de fichiers non traités, il pouvait être manipulé afin de lire tout fichier lisible par l'utilisateur www-data.

  • CVE-2006-1063

    Un attaquant distant pouvait créer ou écraser des fichiers dans n'importe quel répertoire en écriture nommé « mbox ».

  • CVE-2006-1064

    Une mauvaise vérification des entrées permettaient à un attaquant d'injecter des scripts web ou HTML arbitraires.

L'ancienne distribution stable (Woody) ne contient pas le paquet lurker.

Pour l'actuelle distribution stable (Sarge), ces problèmes ont été corrigés dans la version 1.2-5sarge1.

Pour la distribution instable (Sid), ces problèmes ont été corrigés dans la version 2.1-1.

Nous vous recommandons de mettre à jour votre paquet lurker.

Corrigé dans :

Debian GNU/Linux 3.1 (sarge)

Source :
http://security.debian.org/pool/updates/main/l/lurker/lurker_1.2-5sarge1.dsc
http://security.debian.org/pool/updates/main/l/lurker/lurker_1.2-5sarge1.diff.gz
http://security.debian.org/pool/updates/main/l/lurker/lurker_1.2.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/l/lurker/lurker_1.2-5sarge1_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/l/lurker/lurker_1.2-5sarge1_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/l/lurker/lurker_1.2-5sarge1_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/l/lurker/lurker_1.2-5sarge1_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/l/lurker/lurker_1.2-5sarge1_ia64.deb
HPPA:
http://security.debian.org/pool/updates/main/l/lurker/lurker_1.2-5sarge1_hppa.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/l/lurker/lurker_1.2-5sarge1_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/l/lurker/lurker_1.2-5sarge1_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/l/lurker/lurker_1.2-5sarge1_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/l/lurker/lurker_1.2-5sarge1_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/l/lurker/lurker_1.2-5sarge1_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/l/lurker/lurker_1.2-5sarge1_sparc.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.