Debian セキュリティ勧告

DSA-999-1 lurker -- 複数の脆弱性

報告日時:
2006-03-14
影響を受けるパッケージ:
lurker
危険性:
あり
参考セキュリティデータベース:
Mitre の CVE 辞書: CVE-2006-1062, CVE-2006-1063, CVE-2006-1064.
詳細:

セキュリティ関連の問題が複数、 検索エンジンを統合したメーリングリスト用のアーカイブツール lurker に発見されました。The Common Vulnerabilities and Exposures project は以下の問題を認識しています:

  • CVE-2006-1062

    Lurker が設定ファイルを指定する方法は上書きに対して脆弱です。lurker は設定ファイルの解析していない部分をその出力に含めるため、攻撃者は www-data ユーザが読み取れる任意のファイルを lurker に読み込ませることが可能です。

  • CVE-2006-1063

    リモートの攻撃者が「mbox」という名の書き込み可能な、 任意のディレクトリでファイルを作成あるいは上書きすることが可能です。

  • CVE-2006-1064

    入力のサニタイジング欠落により、攻撃者に任意のウェブスクリプトや HTML の差し込みを許します。

旧安定版 (old stable) ディストリビューション (woody) には lurker パッケージは含まれません。

安定版 (stable) ディストリビューション (sarge) では、この問題はバージョン 1.2-5sarge1 で修正されています。

不安定版 (unstable) ディストリビューション (sid) では、この問題はバージョン 2.1-1 で修正されています。

直ちに lurker パッケージをアップグレードすることを勧めます。

修正:

Debian GNU/Linux 3.1 (sarge)

ソース:
http://security.debian.org/pool/updates/main/l/lurker/lurker_1.2-5sarge1.dsc
http://security.debian.org/pool/updates/main/l/lurker/lurker_1.2-5sarge1.diff.gz
http://security.debian.org/pool/updates/main/l/lurker/lurker_1.2.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/l/lurker/lurker_1.2-5sarge1_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/l/lurker/lurker_1.2-5sarge1_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/l/lurker/lurker_1.2-5sarge1_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/l/lurker/lurker_1.2-5sarge1_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/l/lurker/lurker_1.2-5sarge1_ia64.deb
HPPA:
http://security.debian.org/pool/updates/main/l/lurker/lurker_1.2-5sarge1_hppa.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/l/lurker/lurker_1.2-5sarge1_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/l/lurker/lurker_1.2-5sarge1_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/l/lurker/lurker_1.2-5sarge1_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/l/lurker/lurker_1.2-5sarge1_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/l/lurker/lurker_1.2-5sarge1_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/l/lurker/lurker_1.2-5sarge1_sparc.deb

一覧にあるファイルの MD5 チェックサムは勧告の原文にあります。