Bulletin d'alerte Debian

DSA-1261-1 postgresql -- Plusieurs vulnérabilités

Date du rapport :
15 février 2007
Paquets concernés :
postgresql
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2007-0555.
Plus de précisions :

On a découvert que la base de données PostgreSQL ne réalisait pas de vérification de type suffisante sur les paramètres des fonctions SQL ce qui peut conduire à un déni de service ou à la divulgation d'informations.

Pour la distribution stable (Sarge), ce problème a été corrigé dans la version 7.4.7-6sarge4.

Pour la prochaine distribution stable (Etch), ce problème a été corrigé dans la version 8.1.7-1 du paquet postgresql-8.1.

Pour la distribution instable (Sid), ce problème a été corrigé dans la version 8.1.7-1 du paquet postgresql-8.1.

Nous vous recommandons de mettre à jour vos paquets de PostgreSQL.

Corrigé dans :

Debian GNU/Linux 3.1 (sarge)

Source :
http://security.debian.org/pool/updates/main/p/postgresql/postgresql_7.4.7-6sarge4.dsc
http://security.debian.org/pool/updates/main/p/postgresql/postgresql_7.4.7-6sarge4.diff.gz
http://security.debian.org/pool/updates/main/p/postgresql/postgresql_7.4.7.orig.tar.gz
Composant indépendant de l'architecture :
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-doc_7.4.7-6sarge4_all.deb
Alpha:
http://security.debian.org/pool/updates/main/p/postgresql/libecpg-dev_7.4.7-6sarge4_alpha.deb
http://security.debian.org/pool/updates/main/p/postgresql/libecpg4_7.4.7-6sarge4_alpha.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgtcl_7.4.7-6sarge4_alpha.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgtcl-dev_7.4.7-6sarge4_alpha.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpq3_7.4.7-6sarge4_alpha.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql_7.4.7-6sarge4_alpha.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-client_7.4.7-6sarge4_alpha.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-contrib_7.4.7-6sarge4_alpha.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-dev_7.4.7-6sarge4_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/p/postgresql/libecpg-dev_7.4.7-6sarge4_amd64.deb
http://security.debian.org/pool/updates/main/p/postgresql/libecpg4_7.4.7-6sarge4_amd64.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgtcl_7.4.7-6sarge4_amd64.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgtcl-dev_7.4.7-6sarge4_amd64.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpq3_7.4.7-6sarge4_amd64.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql_7.4.7-6sarge4_amd64.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-client_7.4.7-6sarge4_amd64.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-contrib_7.4.7-6sarge4_amd64.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-dev_7.4.7-6sarge4_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/p/postgresql/libecpg-dev_7.4.7-6sarge4_arm.deb
http://security.debian.org/pool/updates/main/p/postgresql/libecpg4_7.4.7-6sarge4_arm.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgtcl_7.4.7-6sarge4_arm.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgtcl-dev_7.4.7-6sarge4_arm.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpq3_7.4.7-6sarge4_arm.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql_7.4.7-6sarge4_arm.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-client_7.4.7-6sarge4_arm.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-contrib_7.4.7-6sarge4_arm.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-dev_7.4.7-6sarge4_arm.deb
HPPA:
http://security.debian.org/pool/updates/main/p/postgresql/libecpg-dev_7.4.7-6sarge4_hppa.deb
http://security.debian.org/pool/updates/main/p/postgresql/libecpg4_7.4.7-6sarge4_hppa.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgtcl_7.4.7-6sarge4_hppa.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgtcl-dev_7.4.7-6sarge4_hppa.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpq3_7.4.7-6sarge4_hppa.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql_7.4.7-6sarge4_hppa.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-client_7.4.7-6sarge4_hppa.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-contrib_7.4.7-6sarge4_hppa.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-dev_7.4.7-6sarge4_hppa.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/p/postgresql/libecpg-dev_7.4.7-6sarge4_i386.deb
http://security.debian.org/pool/updates/main/p/postgresql/libecpg4_7.4.7-6sarge4_i386.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgtcl_7.4.7-6sarge4_i386.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgtcl-dev_7.4.7-6sarge4_i386.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpq3_7.4.7-6sarge4_i386.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql_7.4.7-6sarge4_i386.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-client_7.4.7-6sarge4_i386.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-contrib_7.4.7-6sarge4_i386.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-dev_7.4.7-6sarge4_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/p/postgresql/libecpg-dev_7.4.7-6sarge4_ia64.deb
http://security.debian.org/pool/updates/main/p/postgresql/libecpg4_7.4.7-6sarge4_ia64.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgtcl_7.4.7-6sarge4_ia64.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgtcl-dev_7.4.7-6sarge4_ia64.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpq3_7.4.7-6sarge4_ia64.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql_7.4.7-6sarge4_ia64.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-client_7.4.7-6sarge4_ia64.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-contrib_7.4.7-6sarge4_ia64.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-dev_7.4.7-6sarge4_ia64.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/p/postgresql/libecpg-dev_7.4.7-6sarge4_m68k.deb
http://security.debian.org/pool/updates/main/p/postgresql/libecpg4_7.4.7-6sarge4_m68k.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgtcl_7.4.7-6sarge4_m68k.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgtcl-dev_7.4.7-6sarge4_m68k.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpq3_7.4.7-6sarge4_m68k.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql_7.4.7-6sarge4_m68k.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-client_7.4.7-6sarge4_m68k.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-contrib_7.4.7-6sarge4_m68k.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-dev_7.4.7-6sarge4_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/p/postgresql/libecpg-dev_7.4.7-6sarge4_mips.deb
http://security.debian.org/pool/updates/main/p/postgresql/libecpg4_7.4.7-6sarge4_mips.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgtcl_7.4.7-6sarge4_mips.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgtcl-dev_7.4.7-6sarge4_mips.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpq3_7.4.7-6sarge4_mips.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql_7.4.7-6sarge4_mips.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-client_7.4.7-6sarge4_mips.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-contrib_7.4.7-6sarge4_mips.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-dev_7.4.7-6sarge4_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/p/postgresql/libecpg-dev_7.4.7-6sarge4_mipsel.deb
http://security.debian.org/pool/updates/main/p/postgresql/libecpg4_7.4.7-6sarge4_mipsel.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgtcl_7.4.7-6sarge4_mipsel.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgtcl-dev_7.4.7-6sarge4_mipsel.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpq3_7.4.7-6sarge4_mipsel.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql_7.4.7-6sarge4_mipsel.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-client_7.4.7-6sarge4_mipsel.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-contrib_7.4.7-6sarge4_mipsel.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-dev_7.4.7-6sarge4_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/p/postgresql/libecpg-dev_7.4.7-6sarge4_powerpc.deb
http://security.debian.org/pool/updates/main/p/postgresql/libecpg4_7.4.7-6sarge4_powerpc.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgtcl_7.4.7-6sarge4_powerpc.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgtcl-dev_7.4.7-6sarge4_powerpc.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpq3_7.4.7-6sarge4_powerpc.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql_7.4.7-6sarge4_powerpc.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-client_7.4.7-6sarge4_powerpc.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-contrib_7.4.7-6sarge4_powerpc.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-dev_7.4.7-6sarge4_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/p/postgresql/libecpg-dev_7.4.7-6sarge4_s390.deb
http://security.debian.org/pool/updates/main/p/postgresql/libecpg4_7.4.7-6sarge4_s390.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgtcl_7.4.7-6sarge4_s390.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgtcl-dev_7.4.7-6sarge4_s390.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpq3_7.4.7-6sarge4_s390.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql_7.4.7-6sarge4_s390.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-client_7.4.7-6sarge4_s390.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-contrib_7.4.7-6sarge4_s390.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-dev_7.4.7-6sarge4_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/p/postgresql/libecpg-dev_7.4.7-6sarge4_sparc.deb
http://security.debian.org/pool/updates/main/p/postgresql/libecpg4_7.4.7-6sarge4_sparc.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgtcl_7.4.7-6sarge4_sparc.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgtcl-dev_7.4.7-6sarge4_sparc.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpq3_7.4.7-6sarge4_sparc.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql_7.4.7-6sarge4_sparc.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-client_7.4.7-6sarge4_sparc.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-contrib_7.4.7-6sarge4_sparc.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-dev_7.4.7-6sarge4_sparc.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.