Debians sikkerhedsbulletin

DSA-1275-1 zope2.7 -- udførelse af skripter på tværs af websteder

Rapporteret den:
2. apr 2007
Berørte pakker:
zope2.7
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Debians fejlsporingssystem: Fejl 416500.
I Bugtraq-databasen (hos SecurityFocus): BugTraq-id 23084.
I Mitres CVE-ordbog: CVE-2007-0240.
Yderligere oplysninger:

En sårbarhed i forbindelse med udførelse af skripter på tværs af websteder er fundet i zope, en webapplikationsserver, hvilket kunne gøre det muligt for en angriber at indsprøjte vilkårlig HTML og/eller JavaScript i offerets webbrowser. Koden kunne blive afvilket inde i browserens sikkerhedskontekt, hvilket potentielt kunne gøre det muligt for angriberen at tilgå private oplysninger så som autentificeringscookies, eller til at påvirke zope-websiders fortolkning eller virkemåde.

I den stabile distribution (sarge), er dette problem rettet i version 2.7.5-2sarge4.

I den kommende stabile distribution (etch) og i den ustabile distribution (sid) er zope2.9 indeholdt, og denne sårbarhed er rettet i version 2.9.6-4etch1 i etch og 2.9.7-1 i sid.

Vi anbefaler at du opgraderer din zope2.7-pakke.

Rettet i:

Debian GNU/Linux 3.1 (stable)

Kildekode:
http://security.debian.org/pool/updates/main/z/zope2.7/zope2.7_2.7.5.orig.tar.gz
http://security.debian.org/pool/updates/main/z/zope2.7/zope2.7_2.7.5-2sarge4.diff.gz
http://security.debian.org/pool/updates/main/z/zope2.7/zope2.7_2.7.5-2sarge4.dsc
Alpha:
http://security.debian.org/pool/updates/main/z/zope2.7/zope2.7_2.7.5-2sarge4_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/z/zope2.7/zope2.7_2.7.5-2sarge4_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/z/zope2.7/zope2.7_2.7.5-2sarge4_arm.deb
HP Precision:
http://security.debian.org/pool/updates/main/z/zope2.7/zope2.7_2.7.5-2sarge4_hppa.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/z/zope2.7/zope2.7_2.7.5-2sarge4_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/z/zope2.7/zope2.7_2.7.5-2sarge4_ia64.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/z/zope2.7/zope2.7_2.7.5-2sarge4_m68k.deb
Big-endian MIPS:
http://security.debian.org/pool/updates/main/z/zope2.7/zope2.7_2.7.5-2sarge4_mips.deb
Little-endian MIPS:
http://security.debian.org/pool/updates/main/z/zope2.7/zope2.7_2.7.5-2sarge4_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/z/zope2.7/zope2.7_2.7.5-2sarge4_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/z/zope2.7/zope2.7_2.7.5-2sarge4_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/z/zope2.7/zope2.7_2.7.5-2sarge4_sparc.deb

MD5-kontrolsummer for de listede filer findes i den originale sikkerhedsbulletin.