Säkerhetsbulletin från Debian

DSA-1275-1 zope2.7 -- serveröverskridande skriptproblem

Rapporterat den:
2007-04-02
Berörda paket:
zope2.7
Sårbara:
Ja
Referenser i säkerhetsdatabaser:
I Debians felrapporteringssystem: Fel 416500.
I Bugtraq-databasen (hos SecurityFocus): BugTraq-id 23084.
I Mitres CVE-förteckning: CVE-2007-0240.
Ytterligare information:

En serveröverskridande skriptsårbarhet i zope, en webbprogramserver, kunde göra det möjligt för en angripare att injicera godtycklig HTML- och/eller JavaScriptkod i offrets webbläsare. Denna kod kunde utföras i webbläsarens säkerhetskontext, och möjligen göra möjligt för angriparen att få tillgång till privat data, till exempel autentiseringskakor, eller påverka utseende eller beteende på zope-webbsidor.

För den stabila utgåvan (Sarge) har detta problem rättats i version 2.7.5-2sarge4.

Den kommande stabila utgåvan (Etch) och den instabila utgåvan (Sid) innehåller zope2.9, och denna sårbarhet har rättats i version 2.9.6-4etch1 för Etch och 2.9.7-1 för Sid.

Vi rekommenderar att ni uppgraderar ert zope2.7-paket.

Rättat i:

Debian GNU/Linux 3.1 (stable)

Källkod:
http://security.debian.org/pool/updates/main/z/zope2.7/zope2.7_2.7.5.orig.tar.gz
http://security.debian.org/pool/updates/main/z/zope2.7/zope2.7_2.7.5-2sarge4.diff.gz
http://security.debian.org/pool/updates/main/z/zope2.7/zope2.7_2.7.5-2sarge4.dsc
Alpha:
http://security.debian.org/pool/updates/main/z/zope2.7/zope2.7_2.7.5-2sarge4_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/z/zope2.7/zope2.7_2.7.5-2sarge4_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/z/zope2.7/zope2.7_2.7.5-2sarge4_arm.deb
HP Precision:
http://security.debian.org/pool/updates/main/z/zope2.7/zope2.7_2.7.5-2sarge4_hppa.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/z/zope2.7/zope2.7_2.7.5-2sarge4_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/z/zope2.7/zope2.7_2.7.5-2sarge4_ia64.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/z/zope2.7/zope2.7_2.7.5-2sarge4_m68k.deb
Big-endian MIPS:
http://security.debian.org/pool/updates/main/z/zope2.7/zope2.7_2.7.5-2sarge4_mips.deb
Little-endian MIPS:
http://security.debian.org/pool/updates/main/z/zope2.7/zope2.7_2.7.5-2sarge4_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/z/zope2.7/zope2.7_2.7.5-2sarge4_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/z/zope2.7/zope2.7_2.7.5-2sarge4_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/z/zope2.7/zope2.7_2.7.5-2sarge4_sparc.deb

MD5-kontrollsummor för dessa filer finns i originalbulletinen.