Säkerhetsbulletin från Debian

DSA-1287-1 ldap-account-manager -- flera sårbarheter

Rapporterat den:
2007-05-07
Berörda paket:
ldap-account-manager
Sårbara:
Ja
Referenser i säkerhetsdatabaser:
I Debians felrapporteringssystem: Fel 415379.
I Mitres CVE-förteckning: CVE-2006-7191, CVE-2007-1840.
Ytterligare information:

Två sårbarheter har upptäckts i den version av ldap-account-manager som kommer med Debian 3.1 (Sarge).

  • CVE-2006-7191

    En sårbar obetrodd PATH kunde göra det möjligt för en lokal angripare att exekvera godtyckligkod med förhöjda privilegier genom att tillhandahålla en skadlig rm-binär och ange en PATH-miljövariabel som refererar till denna binär.

  • CVE-2007-1840

    Felaktig teckenersättning i HTML-innehåll kunde göra det möjligt för en angripare att utföra ett serveröverskridande skriptangrepp (XSS) och exekvera godtycklig kod i offrets webbläsare med säkerhetskontexten från den påverkade webbplatsen.

För den gamla stabila utgåvan (Sarge) har detta problem rättats i version 0.4.9-2sarge1. Nyare versioner av Debian (Etch, Lenny och Sid) påverkas inte.

Vi rekommenderar att ni uppgraderar ert ldap-account-manager-paket.

Rättat i:

Debian GNU/Linux 3.1 (oldstable)

Källkod:
http://security.debian.org/pool/updates/main/l/ldap-account-manager/ldap-account-manager_0.4.9-2sarge1.dsc
http://security.debian.org/pool/updates/main/l/ldap-account-manager/ldap-account-manager_0.4.9-2sarge1.diff.gz
http://security.debian.org/pool/updates/main/l/ldap-account-manager/ldap-account-manager_0.4.9.orig.tar.gz
Arkitekturoberoende komponent:
http://security.debian.org/pool/updates/main/l/ldap-account-manager/ldap-account-manager_0.4.9-2sarge1_all.deb

MD5-kontrollsummor för dessa filer finns i originalbulletinen.