Bulletin d'alerte Debian

DSA-1290-1 squirrelmail -- Mauvaise vérification des entrées

Date du rapport :
13 mai 2007
Paquets concernés :
squirrelmail
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2007-1262.
Plus de précisions :

Il a été découvert que le webmail Squirrelmail n'effectuait pas une vérification suffisante des données au sein du filtre HTML, ce qui permettait l'injection de script web arbitraire au moment de l'affichage d'un courriel en HTML.

Pour l'ancienne distribution stable (Sarge), ce problème a été corrigé dans la version 2:1.4.4-11.

Pour l'actuelle distribution stable (Etch), ce problème a été corrigé dans la version 2:1.4.9a-2.

Pour la distribution instable (Sid), ce problème a été corrigé dans la version 2:1.4.10a-1.

Nous vous recommandons de mettre à jour votre paquet squirrelmail.

Corrigé dans :

Debian GNU/Linux 3.1 (sarge)

Source :
http://security.debian.org/pool/updates/main/s/squirrelmail/squirrelmail_1.4.4-11.dsc
http://security.debian.org/pool/updates/main/s/squirrelmail/squirrelmail_1.4.4-11.diff.gz
http://security.debian.org/pool/updates/main/s/squirrelmail/squirrelmail_1.4.4.orig.tar.gz
Composant indépendant de l'architecture :
http://security.debian.org/pool/updates/main/s/squirrelmail/squirrelmail_1.4.4-11_all.deb

Debian GNU/Linux 4.0 (etch)

Source :
http://security.debian.org/pool/updates/main/s/squirrelmail/squirrelmail_1.4.9a-2.dsc
http://security.debian.org/pool/updates/main/s/squirrelmail/squirrelmail_1.4.9a-2.diff.gz
http://security.debian.org/pool/updates/main/s/squirrelmail/squirrelmail_1.4.9a.orig.tar.gz
Composant indépendant de l'architecture :
http://security.debian.org/pool/updates/main/s/squirrelmail/squirrelmail_1.4.9a-2_all.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.