Bulletin d'alerte Debian

DSA-1297-1 gforge-plugin-scmcvs -- Mauvaise vérification des entrées

Date du rapport :
24 mai 2007
Paquets concernés :
gforge-plugin-scmcvs
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2007-0246.
Plus de précisions :

Bernhard R. Link a découvert que l'interface de navigation CVS de Gforge, un outil de développement collaboratif, n'échappait pas correctement les URL, ce qui permettait d'exécuter des commandes arbitraires auprès de l'interpréteur (« shell ») avec les droits de l'utilisateur www-data.

L'ancienne distribution stable (Sarge) n'est pas touchée par ce problème.

Pour l'actuelle distribution stable (Etch), ce problème a été corrigé dans la version 4.5.14-5etch1.

Pour la distribution instable (Sid), ce problème a été corrigé dans la version 4.5.14-6.

Nous vous recommandons de mettre à jour votre paquet gforge-plugin-scmcvs.

Corrigé dans :

Debian GNU/Linux 4.0 (etch)

Source :
http://security.debian.org/pool/updates/main/g/gforge-plugin-scmcvs/gforge-plugin-scmcvs_4.5.14-5etch1.dsc
http://security.debian.org/pool/updates/main/g/gforge-plugin-scmcvs/gforge-plugin-scmcvs_4.5.14-5etch1.tar.gz
Composant indépendant de l'architecture :
http://security.debian.org/pool/updates/main/g/gforge-plugin-scmcvs/gforge-plugin-scmcvs_4.5.14-5etch1_all.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.