Debians sikkerhedsbulletin

DSA-1324-1 hiki -- manglende kontrol af inddata

Rapporteret den:
28. jun 2007
Berørte pakker:
hiki
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Debians fejlsporingssystem: Fejl 430691.
I Mitres CVE-ordbog: CVE-2007-2836.
Yderligere oplysninger:

Kazuhiro Nishiyama fandt en sårbarhed i hiki, en wiki-maskine skrevet i Ruby, hvilket kunne gøre det muligt for en fjernangriber at slette vilkårlige filer, som Hiki-brugere kan skrive til, gennem et særligt fremstillet sessionsparameter.

I den stabile distribution (etch), er dette problem rettet i version 0.8.6-1etch1.

I den ustabile distribution (sid) er dette problem rettet i version 0.8.7-1.

Vi anbefaler at du opgraderer din hiki-pakke.

Rettet i:

Debian GNU/Linux 4.0 (etch)

Kildekode:
http://security.debian.org/pool/updates/main/h/hiki/hiki_0.8.6-1etch1.diff.gz
http://security.debian.org/pool/updates/main/h/hiki/hiki_0.8.6-1etch1.dsc
http://security.debian.org/pool/updates/main/h/hiki/hiki_0.8.6.orig.tar.gz
Arkitekturuafhængig komponent:
http://security.debian.org/pool/updates/main/h/hiki/hiki_0.8.6-1etch1_all.deb

MD5-kontrolsummer for de listede filer findes i den originale sikkerhedsbulletin.