Bulletin d'alerte Debian

DSA-1324-1 hiki -- Vérification d'entrées manquante

Date du rapport :
28 juin 2007
Paquets concernés :
hiki
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 430691.
Dans le dictionnaire CVE du Mitre : CVE-2007-2836.
Plus de précisions :

Kazuhiro Nishiyama a trouvé une vulnérabilité dans hiki, un moteur de Wiki écrit en ruby. Cela peut permettre à un attaquant distant de supprimer des fichiers arbitraires sur lesquels l'utilisateur de Hiki a les droits en écriture, cela via un paramètre de session conçu spécialement.

Pour la distribution stable (Etch), ce problème a été corrigé dans la version 0.8.6-1etch1.

Pour la distribution instable (Sid), ce problème a été corrigé dans la version 0.8.7-1.

Nous vous recommandons de mettre à jour votre paquet hiki.

Corrigé dans :

Debian GNU/Linux 4.0 (etch)

Source :
http://security.debian.org/pool/updates/main/h/hiki/hiki_0.8.6-1etch1.diff.gz
http://security.debian.org/pool/updates/main/h/hiki/hiki_0.8.6-1etch1.dsc
http://security.debian.org/pool/updates/main/h/hiki/hiki_0.8.6.orig.tar.gz
Composant indépendant de l'architecture :
http://security.debian.org/pool/updates/main/h/hiki/hiki_0.8.6-1etch1_all.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.