Рекомендация Debian по безопасности

DSA-1324-1 hiki -- отсутствие очистки ввода

Дата сообщения:
28.06.2007
Затронутые пакеты:
hiki
Уязвим:
Да
Ссылки на базы данных по безопасности:
В системе отслеживания ошибок Debian: Ошибка 430691.
В каталоге Mitre CVE: CVE-2007-2836.
Более подробная информация:

Казухиро Нишияма обнаружил уязвимость в hiki, Wiki-движке, написанном на Ruby, которая может позволить удалённому злоумышленнику удалить произвольные файлы, к которым пользователь Hiki имеет доступ на запись, при помощи специально сформированного параметра сессии.

В стабильном выпуске (etch) эта проблема была исправлена в версии 0.8.6-1etch1.

В нестабильном выпуске (sid) эта проблема была исправлена в версии 0.8.7-1.

Рекомендуется обновить пакет hiki.

Исправлено в:

Debian GNU/Linux 4.0 (etch)

Исходный код:
http://security.debian.org/pool/updates/main/h/hiki/hiki_0.8.6-1etch1.diff.gz
http://security.debian.org/pool/updates/main/h/hiki/hiki_0.8.6-1etch1.dsc
http://security.debian.org/pool/updates/main/h/hiki/hiki_0.8.6.orig.tar.gz
Независимые от архитектуры компоненты:
http://security.debian.org/pool/updates/main/h/hiki/hiki_0.8.6-1etch1_all.deb

Контрольные суммы MD5 этих файлов доступны в исходном сообщении.