Debian Security Advisory

DSA-1344-1 iceweasel -- several vulnerabilities

Date Reported:
03 Aug 2007
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2007-3844, CVE-2007-3845.
More information:

Several remote vulnerabilities have been discovered in the Iceweasel web browser, an unbranded version of the Firefox browser. The Common Vulnerabilities and Exposures project identifies the following problems:

  • CVE-2007-3844

    moz_bug_r_a4 discovered that a regression in the handling of about:blank windows used by addons may lead to an attacker being able to modify the content of web sites.

  • CVE-2007-3845

    Jesper Johansson discovered that missing sanitising of double-quotes and spaces in URIs passed to external programs may allow an attacker to pass arbitrary arguments to the helper program if the user is tricked into opening a malformed web page.

The Mozilla products in the oldstable distribution (sarge) are no longer supported with security updates.

For the stable distribution (etch) these problems have been fixed in version

For the unstable distribution (sid) these problems have been fixed in version

We recommend that you upgrade your iceweasel packages.

Fixed in:

Debian GNU/Linux 4.0 (etch)

Architecture-independent component:
Intel IA-32:
Intel IA-64:
Little endian MIPS:
IBM S/390:
Sun Sparc:

MD5 checksums of the listed files are available in the original advisory.