Debian-Sicherheitsankündigung

DSA-1380-1 elinks -- Programmierfehler

Datum des Berichts:
02. Okt 2007
Betroffene Pakete:
elinks
Verwundbar:
Ja
Sicherheitsdatenbanken-Referenzen:
In der Debian-Fehlerdatenbank: Fehler 443891.
In Mitres CVE-Verzeichnis: CVE-2007-5034.
Weitere Informationen:

Kalle Olavi Niemitalo entdeckte, dass elinks, ein fortgeschrittener textbasierter WWW-Browser, HTTP-POST-Daten im Klartext sendete, wenn ein HTTPS-Proxy-Server verwendet wurde, was möglicherweise die Enthüllung privater Informationen ermöglicht.

Für die Stable-Distribution (Etch) wurde dieses Problem in Version 0.11.1-1.2etch1 behoben.

Für die Unstable-Distribution (Sid) wurde dieses Problem in Version 0.11.1-1.5 behoben.

Wir empfehlen Ihnen, Ihr elinks-Paket zu aktualisieren.

Behoben in:

Debian GNU/Linux 4.0 (etch)

Quellcode:
http://security.debian.org/pool/updates/main/e/elinks/elinks_0.11.1.orig.tar.gz
http://security.debian.org/pool/updates/main/e/elinks/elinks_0.11.1-1.2etch1.diff.gz
http://security.debian.org/pool/updates/main/e/elinks/elinks_0.11.1-1.2etch1.dsc
Alpha:
http://security.debian.org/pool/updates/main/e/elinks/elinks-lite_0.11.1-1.2etch1_alpha.deb
http://security.debian.org/pool/updates/main/e/elinks/elinks_0.11.1-1.2etch1_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/e/elinks/elinks-lite_0.11.1-1.2etch1_amd64.deb
http://security.debian.org/pool/updates/main/e/elinks/elinks_0.11.1-1.2etch1_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/e/elinks/elinks-lite_0.11.1-1.2etch1_arm.deb
http://security.debian.org/pool/updates/main/e/elinks/elinks_0.11.1-1.2etch1_arm.deb
HP Precision:
http://security.debian.org/pool/updates/main/e/elinks/elinks_0.11.1-1.2etch1_hppa.deb
http://security.debian.org/pool/updates/main/e/elinks/elinks-lite_0.11.1-1.2etch1_hppa.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/e/elinks/elinks-lite_0.11.1-1.2etch1_i386.deb
http://security.debian.org/pool/updates/main/e/elinks/elinks_0.11.1-1.2etch1_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/e/elinks/elinks_0.11.1-1.2etch1_ia64.deb
http://security.debian.org/pool/updates/main/e/elinks/elinks-lite_0.11.1-1.2etch1_ia64.deb
Big-endian MIPS:
http://security.debian.org/pool/updates/main/e/elinks/elinks_0.11.1-1.2etch1_mips.deb
http://security.debian.org/pool/updates/main/e/elinks/elinks-lite_0.11.1-1.2etch1_mips.deb
Little-endian MIPS:
http://security.debian.org/pool/updates/main/e/elinks/elinks-lite_0.11.1-1.2etch1_mipsel.deb
http://security.debian.org/pool/updates/main/e/elinks/elinks_0.11.1-1.2etch1_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/e/elinks/elinks_0.11.1-1.2etch1_powerpc.deb
http://security.debian.org/pool/updates/main/e/elinks/elinks-lite_0.11.1-1.2etch1_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/e/elinks/elinks_0.11.1-1.2etch1_s390.deb
http://security.debian.org/pool/updates/main/e/elinks/elinks-lite_0.11.1-1.2etch1_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/e/elinks/elinks_0.11.1-1.2etch1_sparc.deb
http://security.debian.org/pool/updates/main/e/elinks/elinks-lite_0.11.1-1.2etch1_sparc.deb

MD5-Prüfsummen der aufgeführten Dateien stehen in der ursprünglichen Sicherheitsankündigung zur Verfügung.