Debian-Sicherheitsankündigung

DSA-1389-2 zoph -- Fehlende Eingabebereinigung

Datum des Berichts:
18. Okt 2007
Betroffene Pakete:
zoph
Verwundbar:
Ja
Sicherheitsdatenbanken-Referenzen:
In der Debian-Fehlerdatenbank: Fehler 435711.
In Mitres CVE-Verzeichnis: CVE-2007-3905.
Weitere Informationen:

Es wurde entdeckt, dass zoph, ein Web-basiertes Fotoverwaltungssystem, eine unzureichende Eingabebereinigung durchführt, was die Einschleusung von SQL-Kommandos ermöglicht.

Für die alte Stable-Distribution (Sarge) wurde dieses Problem in Version 0.3.3-12sarge3 behoben.

Für die Stable-Distribution (Etch) wurde dieses Problem in Version 0.6-2.1etch1 behoben.

Für die Unstable-Distribution (Sid) wurde dieses Problem in Version 0.7.0.2-1 behoben.

Wir empfehlen Ihnen, Ihr zoph-Paket zu aktualisieren.

Behoben in:

Debian GNU/Linux 3.1 (sarge)

Quellcode:
http://security.debian.org/pool/updates/main/z/zoph/zoph_0.3.3-12sarge3.dsc
http://security.debian.org/pool/updates/main/z/zoph/zoph_0.3.3-12sarge3.diff.gz
http://security.debian.org/pool/updates/main/z/zoph/zoph_0.3.3.orig.tar.gz
Architektur-unabhängige Dateien:
http://security.debian.org/pool/updates/main/z/zoph/zoph_0.3.3-12sarge3_all.deb

Debian GNU/Linux 4.0 (etch)

Quellcode:
http://security.debian.org/pool/updates/main/z/zoph/zoph_0.6-2.1etch1.dsc
http://security.debian.org/pool/updates/main/z/zoph/zoph_0.6-2.1etch1.diff.gz
http://security.debian.org/pool/updates/main/z/zoph/zoph_0.6.orig.tar.gz
Architektur-unabhängige Dateien:
http://security.debian.org/pool/updates/main/z/zoph/zoph_0.6-2.1etch1_all.deb

MD5-Prüfsummen der aufgeführten Dateien stehen in der ursprünglichen Sicherheitsankündigung zur Verfügung.